locked
E-Mail router randomly stops routing incoming mail from forward mailbox RRS feed

  • Question

  • I have installed CRM 4.0 on an SBS machine running SQL 2005 Worgroup SP2 with Exchange 2003 SP2. Everything seems to be working correctly but the e-mail router will at random decide to stop routing mail in the the queues. I have one queue set up sales@xyz and when it is working the mail is correctly removed from the crmsink mailbox I have set up and forwarded in to the queue. After a random interval this stops occuring.

    This problem coccured on a previous installation on this same box. Due to this (And several other reasons) I decided to completely rebuild the server from scratch on Friday night inc a fresh copy of SBS 2003. This problem however has remained. It is therefore either something i did during installation or something that is the same between these two installs. I have no other 3rd party software installed yet.

    The only way to get it going again is to stop and start the CRM E-Mail Router service. The mail then routes correctly again until the next occrance which seems to be around 3 hours. When it stops there are no messages in the event log and the service is still running so outwardly it all looks perfect - It just doesn't route the mail.

    Any help greatly appreciated.

    GG

     

    Saturday, June 7, 2008 2:02 PM

Answers

  • Any time there is a problem with something like the router randomly stopping, I set up a support case with Microsoft.  Given that the service appears to be running and there are no errors in your event viewer, it sounds like you are doing everything right.  MS support can troubleshoot this with you and find the problem.

     

    Monday, June 9, 2008 11:11 AM
    Moderator

All replies