Error while importing existing organization unable to map the users in crm 2011 RRS feed

  • Question

  • Hi All,

    I am trying to import an organization but encountered an error stating that the active directory user must be mapped to at least one enabled microsoft dynamics user who has System Administrator security role. Have mapped and also included server administrator as deployment administrator and tried mapping again still getting the same error.

    Any kind of help will be much appreciated. Please find below the error screen shot

    Thanks in advance

    Sushant Sarkar Microsoft CRM Dynamics Engineer

    Saturday, September 15, 2012 6:38 AM

All replies

  • Hi Sushant,

    It should work if you map the account, however you can do the following: run the deployment manager with the account that is system administrator in the CRM organization you importing and try importing the database again.

    Visit my blog for CRM material, improving performance, kerberos, IFD, development tips, etc. :) http://quantusdynamics.blogspot.com

    Saturday, September 15, 2012 4:58 PM
  • Hi,

    There is a reason of this error. 

    You need to map current user who is running this upgrade with the user who installed the old organization that you are importing. That user was the setup user in old organization. Either use that login for import and select it in above window or check with the below query that who is the SETUPUSER in the restored CRM database which you are trying to upgrade/import and map that user with current user.

    Use <Organization>_MSCRM
    Select * from SystemUser
    Where SetupUser = 1
    If you find a record, then map that user with the user who is currently importing the organization. If there is no record returned by above query, then find a user with system admin role in SystemUser table and make it a setupuser. 

    Use <Organization>_MSCRM Go Update SystemUser Set SetupUser = 1 Where systemuserid = [Current User Systemuser Guid]

    Run import wizard after that and map current user with user that you made setup user in above update statement. Error will go away.

    Best of luck.

    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful" Thanks, Imran Abbasi

    Sunday, September 16, 2012 11:16 AM
  • map any user with system adminstrator role

    select the user click on user mapping browse and select the administrator role

    ms crm

    Monday, September 17, 2012 6:47 AM
  • Hi,

    Did you find the answer to your question on this thread?

    Visit my blog for CRM material, improving performance, kerberos, IFD, development tips, etc. :) http://quantusdynamics.blogspot.com

    Tuesday, October 30, 2012 4:16 PM
  • Hello according to my idea 

    they both r from different organisation he was trying import the database to his organisation

    the problem is user r not matching from previous organisation to this organisation so select the user  and provide the admin or any other privileges then user are  automatically map each other.(or select the user and provide privilege then they map each other)

    if u have queries please raise it to me....

    ms crm

    Wednesday, October 31, 2012 9:52 AM