locked
"Unable to mount backup" at 83% on Vista clients; XP client mounted it fine RRS feed

  • Question

  • Is this a "known issue" to the WHS team? (Googling would indicate I'm not alone.) I'm running the PP3 RCP bits if that makes a difference. Does another report via Connect get it fixed any sooner?

    I NEEDED to restore something. I was somewhat disturbing to find that WHS utterly failed at a major part of one of the primary missions I assign it. I tried rebooting clients and server and still No Joy. Until I tried it on my XP machine and got lucky I was getting pretty concerned... I'm not sure what a WHS user who doesn't have an XP machine sitting around does.
    Monday, November 2, 2009 5:27 PM

All replies

  • I cannot get the XP Machine to mount I have tried several solutions suggested in these forums with no Success.Does anyone have a a full proof solution to this problem.

    And please, do not tell me to go to Connect and file a bug report, thi srelease shoudl be way beyond that type of issue.
    Friday, November 6, 2009 7:21 PM
  • OK Since I have been unable to find a solution to this problem anywhere, here are the steps I took to resolve this and hopefully anyone else looking for a solution may find it here.

    First this solution is only for a WHS Installation that has just been completed and following these steps for someone wanting a solution for a restore that is critical these steps will
    not work.

    Windows Home Server Console: 6.0.1800.0
    Windows Home Server Backup & Restore: 6.0.1800.0
    Windows Home Server Drive Extender: 6.0.1800.0
    Windows Home Server Remote Access: 6.0.1800.0
    Windows Home Server Storage Manager: 6.0.1800.0

    This is with PP1 Only

    1. Un install all Connector Software on all Clients.
    2. Delete the c:\Program Files\Windows Home Server folder on the Clients , and Restart the Client PC.
    3. Perform a Complete New Installation of WINDOWS HOME SERVER. As you can see now, this will erase all drives on the Server. Setup your users as before.
    4. After reinstallation use IE and got http://[server name]:55000 and load the Connector Software. DO NOT USE THE CD TO INSTALL THE CONNECTOR SOFTWARE. I believe this is what caused my problem.

     I selected not to update the collector software if the Server gets updated. I also turned off (for now) Auto Updates. I want to do this a step at a time to see if an update causes the problem later.

    5. Connect to the Server using Connector Software and configure and run a backup on the Client.
    6. After the Backup completes try a restore and see if it has resolved the Cannot Mount Backup error. During the Restore I did get a warning that one of the files it was trying to replace was newer, I selected to not replace it. This was related to the Backup Reader.sys file.

    This worked for me, and even though performing a New Installation was a little bit of a pain it did solve my Cannot Mount Backup error.

    I am testing another Client and after that will look at running Windows update for the WHS.

    The only thing I can conclude is that the Windows Update is not updating the Connect Software correctly as I kept getting the Server Connect software does not match the server error when I ran the WHSToolkit. Even though I un installed and deleted the Server Connect software and folders several times, I believe the Server Connect Software was still not matching the server.


    Tuesday, November 10, 2009 7:18 PM