none
Issues with one user in Acttive Sync RRS feed

  • Question

  • I've got the curliest of curly situations here

    Exchange 2003 (SBS to be precise) and Active sync issues just for one user

    We have about 4 users which have active sync on their devices (apple iphones) and their mailboxes connect, download mail, can send receive and all that good stuff

    However for just one user it simply refuses to work properly

    Now the strange thing is that the user appears to authenticate properly on their phone, i.e. when you run through the exchange active sync setup it completes it and shows all of the users folders. However, the items within said mailbox do not show - a total of zero items are shown for the whole mailbox.

    I've seen a few posts out there about subfolders not synching over active sync - but there are plenty of folders showing, including the inbox. Just no items within the folders

    I thought that it may be an iphone specific issue - so I've tried with an Android device and it does exactly the same thing

    OWA and OMA via internet explorer works fine

    SSL is enabled, but not enforced on the server. Testexchangeconnectivity.com passes for both SSL and non SSL connectivity

    Now, the interesting part is this. I know the credentials for this user are fine as we have disabled and re-enabled the account; as well as reset the password. The IIS logs show the following:

    401 errors against the OMA virtual directory for this user!

    A working user shows the following:

    200 errors against the OMA virtual directory

    So this is what has me stumped. The user is ok, the virtual directory is ok (I rebuilt it from scratch as part of the diagnostic steps) I've increased the kerberos ticket size to the maximum - but still no go.

    Im lost! Please help

    Tuesday, March 12, 2013 7:15 AM