SyncToy 2.1 won't sync with my external HDD RRS feed

  • Question

  • I have been using SyncToy 2.1 on several my PCs which are in the same Home Group and runs Windows 7.

    Several different scripts have been running successfully to keep things updated:

    1) Sync Public on System A with Public on System B.

    2) Sync Public on System B with external HDD on System B.

    Recently I ran out of room on the C: drive of system B so I am planning to start synching directly from System A to the external HDD on System B. I initially had some problems with write privileges but I resolved that. My first update was rather small but seemed to be correct. All of my files are WMA audio and I sometimes make changes to the tags. When I did that this evening on System A I confirmed that the file modification date was updated in MP3Tag (my tag editor). Unfortunately SyncToy did not detect any changes and refused to sync on the external HDD. In the past I did this sort of thing all the time with script 1 (see above) and never had any problems.

    So what is preventing SyncToy from noticing that the files need to be updated?

    Monday, June 20, 2011 2:21 AM

All replies

  • You might be able to get it to work by using the "Check file contents" folder-pair option.

    Unfortunately it may also slow the syncing process down quite a bit as the SHA1 hashes for the files are computed and compared. You should need to do this if the MP3 tag editor changes the file's timestamp when you make changes to the tags (as it should by default).


    Monday, June 20, 2011 10:18 AM
  • I agree that might work and it is probably very slow since I have over 15,000 files.


    I would really like to understand why everything worked fine for the last year with my other configurations.

    The only difference here is that the destination is folder on an external HDD mapped through a Home Group.

    I don't believe that should have any effect on the operation of SyncToy but it is a mystery.


    I will try adding "Check file contents" tonight and see how abysmal performance is.

    Monday, June 20, 2011 4:46 PM
  • I tried SyncToy again and the results were very bizarre.

    I edited one audio file and then also updated the MP3 tag data. SyncToy did not detect any change in the directory tree.

    Next I added the "check file contents" option and ran "Preview". The scan took about 15 minutes (880 files) and 80 files were flagged for copying. None of those files that were tagged had been changed recently. My most recent change was once again, not detected.

    I manually opened the file properties on the file I changed and it clearly says "updated 29 minutes ago".


    Once again I am left wondering why everything worked just fine with my previous use of this tool.

    Monday, June 20, 2011 11:04 PM
  • I found the problem.


    As I mentioned in the previous post only 880 files were scanned instead of 15,000.

    I was missing a file extension parameter in the new configuration, it was hidden off the screen in my other configuration.


    Monday, June 20, 2011 11:16 PM