locked
Creating Entity Class XRM.cs which gives error? RRS feed

  • Question

  • I ma trying to generate the early bounds for the web application walkthrough but whenever I try to do this by runing the command 

    CrmSvcUtil.exe /codeCustomization:"Microsoft.Xrm.Client.CodeGeneration.CodeCustomization, Microsoft.Xrm.Client.CodeGeneration" /out:Xrm\Xrm.cs /url:http://10.10.10.15/Organization/XRMServices/2011/Organization.svc /domain:LAB /username:foo /password:foo464 /namespace:Xrm /serviceContextName:XrmServiceContext


    Following the Instructions. It gives me some errors after running it many times, which are given below

    (One error given at a time but i have got all these error one at a time when i tried to generate the class using the command)

     Exiting program with exception: The socket connection was aborted. This could be
     caused by an error processing your message or a receive timeout being exceeded
    by the remote host, or an underlying network resource issue. Local socket timeou
    t was '00:05:00'.
    Enable tracing and view the trace files for more information.



    Exiting program with exception: Could not find a part of the path 'C:\Users\Rana
     Waqas\Desktop\CRM installations\SDK\Bin\Xrm\Xrm.cs'.
    Enable tracing and view the trace files for more information.




    Exiting program with exception: The request channel timed out while waiting for
    a reply after 00:04:59.8539917. Increase the timeout value passed to the call to
     Request or increase the SendTimeout value on the Binding. The time allotted to
    this operation may have been a portion of a longer timeout.
    Enable tracing and view the trace files for more information.


    Exiting program with exception: The caller was not authenticated by the service.

    Enable tracing and view the trace files for more information.



    Unhandled Exception: System.NullReferenceException: Object reference not set to
    an instance of an object.
       at Microsoft.Crm.Services.Utility.CrmSvcUtil.Main(String[] args)

    I am not quite sure what is the problem, please help me solve this.


    Rana Muhammad Waqas

    Monday, July 14, 2014 9:20 AM

Answers

  • Problem Resolved 

    1. Make a folder named Xrm in ".../SDK/Bin/" and place a empty file named Xrm.cs there 
    2. Make sure your machine and the server which is running the CRM on premise have the same timezone and same time 
    3. Restart your computer 
    4. Try it now it works now for me 

    Rana Muhammad Waqas

    Tuesday, July 15, 2014 10:42 AM

All replies

  • Problem Resolved 

    1. Make a folder named Xrm in ".../SDK/Bin/" and place a empty file named Xrm.cs there 
    2. Make sure your machine and the server which is running the CRM on premise have the same timezone and same time 
    3. Restart your computer 
    4. Try it now it works now for me 

    Rana Muhammad Waqas

    Tuesday, July 15, 2014 10:42 AM
  • Hi Rana,

    Mark the post as Answered, so that it could help others.

    --

    Regards,

    Gopinath.

    Tuesday, July 15, 2014 6:36 PM