locked
Outlook Client Configuration Wizard Issue: RRS feed

  • Question

  • Outlook Client Configuration Wizard Issue:

                I am trying to setup MS CRM 4.0 server and outlook client on the same machine.  I have successfully installed MS CRM 4.0 workgroup edition on my windows 2003 R2 server and everything appears to be running correctly.  After installing the ‘Outlook Client’ I try to configure it using the ‘Configuration Wizard’ and connecting to the CRM instance at ‘My Computer’ but receive the following error:

     

    Error:

    Client found response context type of ‘text/html; charset=utf-8’, but expected ‘text/xml’.  The request failed with the error message:

    --

     

    <html>

    <head>

    <link rel=”SHORTCUT ICON” href=”/favicon.ico” />

    <META HTTP-EQUIV=”Content-Type” CONTECT=”text/html; CHARSET=utf-8”>

    <script type=”text/javascript”>

    Var LOCID_FORM_REQUIRED_BKG_COLOR = “”;

    Var LOCID_FORM_REQUIRED_ALT = “Required”;

    Var LOCID_COPY_SHORTCUT_ERROR = “The shortcut could not be copied to the clipboard”;

    Var LOCID_UI_DIR = “LTR”;

    Var LOCID_AM_DESIGNATOR = “AM”;

    Var LOCID_PM_DESIGNATOR = “PM”;

    Var LOCID_FIRST_WEEK_SELECT = “FirstDay”;

    Var LOCID_UNRECOGNIZE_DOTC = “x7bo\x7d is not a recognized Object type.”;

    Var LOCID_XML_PROCESS_ERROR = “There was an error processing your request. Please wait and try again later.”;

    Var LOCID_POPUP_BLOCKER_ERROR = “A Microsoft Dynamic CRM window was unable to open, and may have been blocked by a pop-up blocker.  Please add this Mircosoft Dynamic CRM server to the list of sites your pop-up blocker allows to open new windows\x3a”;

    Var LOCID_BU_CANNOTDISABLE = “It has been detected that this operation would deactivate all remaining business units and cannot proceed.”;

    Var LOCID_DIALOG_OFFEST_WIDTH = “0”;

    Var LOCID_DIALOG_OFFSET_HEIGHT = “0”;

    Var LOCID_ERROR_DIALOG_WIDTH = “550”;

    Var LOCID_ERROR_DIALOG_HEIGHT = “260”;

    Var LOCID_CONTRACTS_TDIALOG_WIDTH = “350”;

    Var LOCID_CONTRACTS_TDIALOG_HEIGHT = “350”;

    Var LOCID_REMOTECOMMAND_ERROR = “An Error has occurred. Try this action again.  If the problem continues, check the Microsoft Dynamics CRM Community for solutions or contact your organization\x27s Microsoft Dynamics CRM Administrator.  Finally, you can contact Microsoft Support.”;

     

    Var WEB_APP_URL = “”;

    Var EHLP_SKU = “OP”;

    Var _bInvalidSitemap = false;

    Var _bShowRegistrationReminder = false;

    Var _bShowTrialReminder = false;

    Var REMIND_AUTH_EXPIRATION = true;

    Var AUTH_EXPIRATION_REMINDER_TIME_IN_MINUTES = 0;

    Var IS_LIVE = false;

    Was IS_PATHBASEDURLS = true;

    Var ORG_UNIQUE_NAME = “TestDynamicDRM”;

    Var _ErrorCodesIsvAborted = “0x80040265”;

    Var ScriptErrorReportingPreference = 1;

    Var ScriptErrorStatusBar = “Error on page.”;

    Var _bPresenceEnabled = true;

               

     

    System Setup:

                Windows Server 2003 R2

                Dynamic CRM 4.0 workgroup edition

                MS Outlook 2007

                SQL Server 2005 enterprise edition

     

    I would appreciate any insight you can provide to help resolve this error. 

    Thank you,
    Monday, March 3, 2008 3:20 PM

Answers

  • There is no setting in Outlook (that I know of) to do with Pop-up blocking. 

     

    I've been looking at the original error message that you posted.  A few bits seem odd:

     

    Var LOCID_BU_CANNOTDISABLE = “It has been detected that this operation would deactivate all remaining business units and cannot proceed.”;

    Var REMIND_AUTH_EXPIRATION = true;

    Var ORG_UNIQUE_NAME = “TestDynamicDRM”;

     

    Did you have an earlier trial installation that has since expired?

     

    Perhaps you should remove all traces of the CRM Outlook client and start again. First Use Add/Remove Programs to get rid of the CRM Outlook Client and remove the SQL Express database (if using Offline).

     

    Try reinstalling CRM Outlook and see where that leaves you.

     

     

    Monday, March 3, 2008 8:26 PM
    Moderator
  • Resolution:

    It works!  In the C:\Program Files\Microsoft Dynamic CRM – Outlook folder is a Default_Client_Config.xml file.  I updated the file with values that applied to my local system then ran the configuration wizard again and everything configured successfully.  After the configuration I encountered an error when opening Outlook but restarting the PC resolved that.  From what I can tell everything with the Outlook client is working correctly.  Thank you to Feridun Kadir and Imran for the help.

     

    Monday, March 3, 2008 10:45 PM

All replies

  • use the diagnostic wizard for CRM 4.. client

     

    check this

     

    http://support.microsoft.com/kb/911384/en-us

     

    http://support.microsoft.com/kb/947423/en-us

     

    Regards,

    Imran

     

    http://microsoftcrm3.blogspot.com

     

    Monday, March 3, 2008 4:54 PM
    Moderator
  • Imran,

                When I run the diagnostic wizard I receive error message: “CRM for Outlook has not been configured.  Run the CRM Configuration Wizard and then rerun CRM Diagnostics”.

     

                The http://support.microsoft.com/kb/947423/en-us kb article makes mention of several registry entries that I do not have, these being:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\MSCRMClient\IntranetDiscoveryUrl

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\MSCRMClient\IntranetServerUrl

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\MSCRMClient\IntranetWebAppUrl

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\MSCRMClient\PlatformRoot

                Any idea why I am missing these entries?  Could this be related?

     

                A little more information about the original error, after the main error message is closed a secondary message pops up stating: “Mandatory updates for Microsoft Dynamic CRM could not be applied successfully.  Try running the application again.”  I appreciate your advice.

    Thank you,
    Monday, March 3, 2008 5:19 PM
  • I think the secondary message is misleading and might not be relevant.

     

    Are you able to get to CRM in the web client?  Your first post suggests that a pop-blocker might be enabled (perhaps Google tool-bar?). Did you check this?

     

     

    Monday, March 3, 2008 6:19 PM
    Moderator
  • Feridun Kadir,

                I tried making the localhost a trusted site within IE 7 and made sure ‘Pop-up Blocker \ Turn On Pop-up Blocker’ was not checked under the Tools menu of IE7.  Is there another way to turn off pop-up blocking?  Does something within Outlook need to be changed?  The web client works great, I’m just not able to configure outlook.  Thanks for the help.

     

    Monday, March 3, 2008 6:52 PM
  • There is no setting in Outlook (that I know of) to do with Pop-up blocking. 

     

    I've been looking at the original error message that you posted.  A few bits seem odd:

     

    Var LOCID_BU_CANNOTDISABLE = “It has been detected that this operation would deactivate all remaining business units and cannot proceed.”;

    Var REMIND_AUTH_EXPIRATION = true;

    Var ORG_UNIQUE_NAME = “TestDynamicDRM”;

     

    Did you have an earlier trial installation that has since expired?

     

    Perhaps you should remove all traces of the CRM Outlook client and start again. First Use Add/Remove Programs to get rid of the CRM Outlook Client and remove the SQL Express database (if using Offline).

     

    Try reinstalling CRM Outlook and see where that leaves you.

     

     

    Monday, March 3, 2008 8:26 PM
    Moderator
  • Resolution:

    It works!  In the C:\Program Files\Microsoft Dynamic CRM – Outlook folder is a Default_Client_Config.xml file.  I updated the file with values that applied to my local system then ran the configuration wizard again and everything configured successfully.  After the configuration I encountered an error when opening Outlook but restarting the PC resolved that.  From what I can tell everything with the Outlook client is working correctly.  Thank you to Feridun Kadir and Imran for the help.

     

    Monday, March 3, 2008 10:45 PM
  • Could you show current configuration your "Default_Client_Config.xml". I have got same error as you.

    Tuesday, March 25, 2008 3:17 PM
  • Kriger,

                Here is the revised ‘Default_Client_Config.xml’ file.

     

    Revised Version:

    Code Snippet

    <?xml version="1.0" encoding="utf-8"?>

    <CRMConfiguration>

      <Client>

        <!--

        <ServerUrl Type="OnPremise|Live|SPLA" ShowUser="True|False">http://PathToDiscoveryService</ServerUrl>

        

        Specifies the details to connect to Microsoft Dynamics CRM.

         Type - Determines the type of deployment:

          - "OnPremise" - For users on Microsoft Dynamics CRM with Active Directory authentication.

          - "Live" - For users on Microsoft Dynamics Live CRM.

          - "SPLA" - For users on Microsoft Dynamics CRM through a hosting partner.

            

         ShowUser - Determines whether the "Connect to Microsoft Dynamics CRM" screens are displayed to the user.

                  - "True" - Will show this screen (default).

          - "False" - Will not show this screen.  

          

         Specifying a URL is optional when the deployment type is Live. For OnPremise and SPLA, this should be the path to the Discovery Service.

        -->

     

        <ServerUrl Type="OnPremise" ShowUser="True">http://localhost:5555/TestDynamicCRM/loader.aspx</ServerUrl>

     

        <!--

        <ExtranetServerUrl>http://PathToExternalDiscoveryService</ExtranetServerUrl>

        For OnPremise deployments that are configured to be Internet-facing, the ExtranetServerUrl should point to the External Discovery Service.

        -->

        <ExtranetServerUrl>http://localhost:5555/TestDynamicCRM/loader.aspx</ExtranetServerUrl>

     

        <!--

        <Organization>OrganizationName</Organization>

        Specifies the unique name of the organization.

        -->

        <Organization>TestDynamicCRM</Organization>

     

        <!--

        <CEIP option="True|False" />

        Specifies whether you allow Microsoft to collect anonymous data from your deployment to help improve future versions of the software.

        -->

        <CEIP option="True" />

     

        <!--

        <Database Reuseexisting="True | False"/>

        For users of Microsoft Dynamics CRM for Outlook with Offline Access, this flag specifies whether you want to reuse a previously attached database.

        -->

        <Database Reuseexisting="True"/>

      </Client>

    </CRMConfiguration>

     

     

    Hope it resolves your issue:

    Jason

    Tuesday, March 25, 2008 8:22 PM
  • Thank you, but i am still getting error "The request failed with HTTP status 401: Unauthorized"

    Do you have any idea about
    this issue?

    Web access works fine.
    Tuesday, April 1, 2008 3:06 PM
  • Did you ever resolve this issue?  I am trying to configure the CRM 4.0 Outlook client on a non-Active Driectory domain computer.  When the configuration wizard asks for a URL, the server location is entered (using port 5555 - no host headers).  When the Next button is pressed, the error "The request failed with HTTP status 401: Unauthorized" pops up.  I can't find anything on this error.  The few things that I found, which seemed to give a fix for similar errors, did not work.  I sure would like to know how you fixed this if you did.

     

    By the way, when the client is configured on a domain computer, there is no error.



    Tuesday, May 27, 2008 9:43 PM
  • Here is further information on the problem with configuring the Outlook CRM client.  The diagnostic program was run and everything passed except the network connectivity test.  The indication is the CRM server at http://server2:5555/ESACRM is not responding.  However, when I open up a browser and enter that same address on the same computer, the CRM web client comes up immediately.  Any ideas?  I sure would appreciate it.

     

     

    Verifying Web access.</Title>

      <Status>Failed</Status>
      <Details>Microsoft.Crm.Outlook.Diagnostics.DiagnosticCheckException: The Web address (URL) specified for the installation (http://server2:5555/ESACRM) is not responding. Diagnostic tests that require connectivity will not be run. Verify the specified Web service address and check for connectivity. If necessary, rerun the CRM Configuration Wizard. ---> System.Net.WebException: The remote server returned an error: (401) Unauthorized. at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request) at System.Net.WebClient.DownloadData(Uri address) at System.Net.WebClient.DownloadData(String address) at Microsoft.Crm.Outlook.Diagnostics.ApplicationEndpointDiagnosticCheck.Execute(BackgroundWorker backgroundWorker) --- End of inner exception stack trace --- at Microsoft.Crm.Outlook.Diagnostics.ApplicationEndpointDiagnosticCheck.Execute(BackgroundWorker backgroundWorker) at Microsoft.Crm.Outlook.Diagnostics.DiagnosticCheck.DeepExecute(BackgroundWorker backgroundWorker)</Details>
    Wednesday, May 28, 2008 2:14 PM
  • I have just solved this problem. CRM didn't recognized the remote machine by the IP address. I had to put an entry in the hosts file of my pc pointing to the CRM server name / ip.
    In the configuration wizard window I had just put the CRM server name and port and worked fine.

    I hope it helps,
    Friday, June 6, 2008 6:12 PM
  •  tlombardi wrote:

    Did you ever resolve this issue?  I am trying to configure the CRM 4.0 Outlook client on a non-Active Driectory domain computer. and site remote statioon. how will this.  When the configuration wizard asks for a URL, the server location is entered (using port 5555 - no host headers).  When the Next button is pressed, the error "The request failed with HTTP status 401: Unauthorized" pops up.  I can't find anything on this error.  The few things that I found, which seemed to give a fix for similar errors, did not work.  I sure would like to know how you fixed this if you did.

     

    By the way, when the client is configured on a domain computer, there is no error.



    Saturday, January 10, 2009 9:14 AM
  • In the configuration wizard you have two options: My Company and Internet address. Try to choose the internet addres, using the crm server ip.

    I hope it helps.
    Monday, January 12, 2009 11:34 AM
  • On a similar, but different note.....

    Did anyone have any issues with the default_client_config accepting your ExtranetServerUrl setting? No matter what I do, the ExtranetServerUrl does not appear correctly in the Configuration Wizard. Instead the "Use the same Web address when the system connects over the Internet" is checked off and therefore it uses the ServerUrl, not the ExtranetServerUrl.

    Has anyone else noticed this?

    Regards,

    Graeme
    Wednesday, February 11, 2009 5:09 PM
  • KB954302

    Error message when you run the Microsoft Dynamics CRM Configuration Wizard of the Microsoft Dynamics CRM 4.0 client for Outlook: "The request failed with HTTP status 401: Unauthorized"

    To resolve this problem, use one of the following methods:
    • If you use the An online service provider option when you run the Microsoft Dynamics CRM Configuration Wizard, make sure that the IP address of the client is not included in the InternalNetworkAddress registry subkey.
    • If you use the My company option when you run the Microsoft Dynamics CRM Configuration Wizard, make sure that the IP address of the client is included in the InternalNetworkAddress registry subkey.
    Notes
    • If the Microsoft Dynamics CRM client for Outlook users contains internal users and external users, we recommend that you configure the Microsoft Dynamics CRM client for Outlook by using the My company option and make sure that the IP address of the client is included in the InternalNetworkAddress registry subkey. Therefore, you can specify the intranet address and the external Web address when you configure the Microsoft Dynamics CRM client for Outlook.
    • If the Microsoft Dynamics CRM client for Outlook users contains only external users, you can configure the Microsoft Dynamics CRM client for Outlook by using the An online service provider option. Therefore, you can only specify the external Web address when you configure the Microsoft Dynamics CRM client for Outlook.
    To define the InternalNetworkAddress registry key, use the Microsoft Dynamics CRM Internet-Facing Deployment (IFD) Configuration tool.

    Note the InternalNetworkAddress registry subkey is located in the following registry key of the Microsoft Dynamics CRM server:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM\IfdInternalNetworkAddress


    Your Trusted Technology Partner
    Friday, February 13, 2009 7:22 PM