none
'Microsoft.SqlServer.MgdSqlDumper.dll' RRS feed

  • Question

  • When I try to launch Microsoft Power BI, I get the following error message:

    Could not load file or assembly

    'Microsoft.SqlServer.MgdSqlDumper.dll' or one of its dependencies.
    The referenced assembly is not installed on your system, 
    (Exception 
    from HRESULT: Ox800736B3) 

    Have posted to the Power BI  Community and have not gotten a response.

    Have tried Microsoft support to see if I could download the missing assembly. Was instructed to use the System File Checker to repair missing or corrupted system files but cmd line sfc /scannow would not run.

    Also Windows 10 will not upgrade to newest build. The machine, a Dell Inspirion, came with Windows 7 pre-installed and I updated to WIndows 10 a couple years ago. Until now no problem.

    I've been able to install Power BI on two other machines which also have the Windows 10 upgrade from a pre-installed earlier version with no problems.

    Sunday, May 14, 2017 4:01 PM

All replies

  • Hello,

    Report Builder installs that DLL:

    https://www.microsoft.com/en-us/download/details.aspx?id=29072



    Hope this helps.



    Regards,

    Alberto Morillo
    SQLCoffee.com

    Monday, May 15, 2017 3:21 PM
  • Hi dprint,

    I’ve reached out with PowerBI support team to ask them to have a look into the issue. 

    Thanks for your understanding and support.

    Regards,
    Lin

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, May 17, 2017 4:53 AM
  • Hello Lin,

    I am having identical issues (same error with 'Microsoft.SqlServer.MgdSqlDumper.dll'), where Power BI is not loading, any pointers to the solution?

    kind regards

    Deepak


    Friday, April 19, 2019 1:49 PM