locked
Setting CRM 2011 for mutliple front end servers on a cluster enviornment. RRS feed

  • Question

  • Hi,

    We have two front end servers configured as http....

    http://front-end-server1

    http://front-end-server2

    the cluster URL is secure : https://crm-app ... this is a load balanced URL  (f5) that will go to one of the front end server on port 80....

    When I use the URL https://crm-app to configure outlook ...i'm getting error....but outlook can be configured using the front-end servers URL (http)....Is there any CRM settings I need to update to make it work !!!!

    Friday, October 11, 2013 5:28 AM

All replies

  • There is a setting in the Deployment Manager. Right-click on Microsoft Dynamics CRM in the navigation pane, then click Properties and then click the Web Address tab. Then click Advanced. You will see a page where you can specify settings for an NLB.  I hope this is what you need.
    Thursday, October 17, 2013 7:46 AM
    Moderator
  • Hi Feridun,

    Thanks for the reply. I have played with those settings and still get the same error. 

    One thing that I have noted is ...the Discovery & Organization service has the https URL (1) but the call to the wsdl has the http URL (2) .......I have verified this thru the developer resource section under customization on the CMR web app....

    1. https://crm-app/XRMServices/2011/Discovery.svc

    2. http://crm-app/XRMServices/2011/Discovery.svc?wsdl   **** Doesn't work and outlook plugin fails....

    Any help is appreciated. Thanks!

    Tuesday, October 22, 2013 12:29 AM
  • The http setting in your item 2 is odd. My understanding is that everything is either https or http, you can't have mix.

    Do you have multiple bindings in the CRM website in IIS? If so, that is not supported. There must only be one.

    My system is configured for https and when I look in Developer Resources all the links start with https.

    Tuesday, October 22, 2013 8:24 PM
    Moderator
  • Hi Feridun,

    We only have http binding for CRM website in IIS. But the cluster URL is https (as mentioned in my initial post)...... If i update the properties for CRM in deployment manager.....

    and set it to https to map cluster URL..... I have the above scenario.

    On the other hand if I have don't update the deployment manager properties and leave it to point to one of the CRM servers as http......I still can't configure outlook using cluster URL  https://crm-app because it is secure and it will call the discovery service as

    https://front-end-server1/XRMServices/2011/Discovery.svc and it doesn't exist.


    Wednesday, October 23, 2013 3:38 AM
  • The settings in the Deployment Manager should definitely match the binding in IIS. So you should leave the web addresses as http.

    Does this article help: http://support.microsoft.com/kb/2642455

    Wednesday, October 23, 2013 3:22 PM
    Moderator