none
Framework 4.0 Reinstall not completely/properly installed RRS feed

  • Question

  • Having issues with Visual Studio and Crystal Reports, I uninstalled Crystal Reports for Visual Studio, and ran the latest CR for VS 13.0.3500.  It flagged errors registering 6 of the dlls with 4902 ( Framework 4.0 errors?).  So, trying:

    1. Reinstall Framework 4.0 FULL 32x86 it says already installed.

    2. Uninstall Framework 4.0.  Run install again.  Same error. (and Visual Studio of course can't select Framework 4)

    3. Walking thru diagnoses procedures, I ran NetFxRepairTool.  

    4. Run Framework 4.0 Full again, same error, even with 4.0 not installed.  The html file in %temp%  says Success. No errors.

    I DO NOT see Framework 4.0 in the Uninstall a Program.

    5. Ran Visual Studio rebuild, which takes hours. It sees Framework 4.0

    6. Reinstalled Crystal Reports for Visual Studio .exe as Administrator.  Same Errors.

    7. Last night there was a Windows Update, and it updates all the Frameworks I have, but NOT 4.0, which tells me 4.0 is really not installed correctly.

    Not sure what else to try to get a complete 4.0 reinstall working, which hopefully will then fix the Crystal Report Engine installer.  Thanks

    Wednesday, September 12, 2018 4:44 PM

All replies

  • Hi E-NovativeGuy,

    Thank you for posting in MSDN forum!

    Refer to your description, it seems this issue is about the Crystal report development. Since our forum is to discuss the VS installation issues, please redirect to SAP Crystal Reports Community and start a new thread for a better support, thank you for your understanding.

    Best Regards,


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thursday, September 13, 2018 3:21 AM