locked
Ribbon item is dependent on ribbon control RRS feed

  • Question

  • Hi,

    I am importing an unmanaged solution into another organization(upgrading the solution). But it fails and shows this error.

    The ribbon item 'new.Mscrm.SubGrid.activitypointer.AdvMergeRecords.Hide' is dependent on ribbon control id='Mscrm.SubGrid.activitypointer.AdvMergeRecords'.

    What does this mean?

    Thanks

    Thursday, December 11, 2014 4:58 PM

All replies

  • Hi,

    This kind of error will occur, when you try to remove the ribbon display rule item ('new.Mscrm.SubGrid.activitypointer.AdvMergeRecords.Hide') and this ribbon item still using by a ribbon control ('Mscrm.SubGrid.activitypointer.AdvMergeRecords') .

    So open the customization xml file in the solution and check these item names in the RibbonDiffXml (you might have missed the ribbon item 'new.Mscrm.SubGrid.activitypointer.AdvMergeRecords.Hide' from the RibbonDiffXml

    Thanks,

    Seban

    Friday, December 12, 2014 11:11 AM
  • I do see the below line in RibbonDiffXml.

    <HideCustomAction HideActionId="new.Mscrm.SubGrid.activitypointer.AdvMergeRecords.Hide" Location="Mscrm.SubGrid.activitypointer.AdvMergeRecords" />

    Also, I don;t think I've hidden this item as I never used or worked with 'Activity Pointer' entity.

    Thanks
    Friday, December 12, 2014 1:53 PM
  • Hi,

    <HideCustomAction> used to remove an existing ribbon element from the ribbon.

    If you dont want to hide the control 'Mscrm.SubGrid.activitypointer.AdvMergeRecords' , then remove the line <HideCustomAction HideActionId="new.Mscrm.SubGrid.activitypointer.AdvMergeRecords.Hide" Location="Mscrm.SubGrid.activitypointer.AdvMergeRecords" /> from ribbon diff xml and try to import solution

    Thanks,
    Seban


    Friday, December 12, 2014 3:09 PM
  • I tried to unhide that control in Ribbon workbench and published the changes. But it is not publishing the changes and is throwing the same error.

    The ribbon item 'new.Mscrm.SubGrid.activitypointer.AdvMergeRecords.Hide' is dependent on ribbon control id='Mscrm.SubGrid.activitypointer.AdvMergeRecords'.

    I am not understanding how this error is connected to importing solution and changing the ribbon workbench!

    Thanks

    Sunday, December 14, 2014 8:42 PM
  • Hi,

    Can you specify the changes you did related to any ribbon element like adding a button or adding any dispaly rules. This would help to narrow down on the issue.

    Meanwhile double check you entity name for any spelling mistake if you have manually edited it.

    Thanks,

    Prasad

    Make sure to "Vote as Helpful" and "Mark As Answer",if you get answer of your question.

    Monday, December 15, 2014 5:17 AM
  • Is Activity Entity Part of your solution you are importing? If not Please add it. 


    Regards, Saad

    Monday, December 15, 2014 6:11 AM
  • I haven't made any change to the ribbon of Activity entity. I wonder how a button is hidden. Like I said I tried to delete that rule but it is not letting me do it too!

    Also, ActivityPointer doesn't have any forms right? Then how can a change happen in its ribbon I wonder?

    Thanks

    Monday, December 15, 2014 1:49 PM
  • hey i faced the same issue!

    i was not able to find out the reason causing the error may be u might have to make a new solution fro workbench start afresh improting the entities and then make the changes. I was able to remove the error with that.

    Hope that helps

    Friday, April 10, 2015 8:55 AM
  • Hi Surbhi,

    Did the above issue resolved?

    even I am facing the same issue.

    please help me out in resolving this.

    Saturday, June 13, 2015 12:11 AM
  • Do you have any managed solutions installed that impact this entity? In the past I have sometimes needed to export entity unmanaged, backup customisations.xml, edit original to vanilla (blank) ribbondiffxml, import, then re-apply ribbon customisations.
    Monday, June 15, 2015 8:25 AM
  • Hello Chris,

    We are using CRM 2013 Onpremises. Recently updated the ROll Ups (1 and 2). and We upgraded Ribbon Workbench also to 2.0.0.7 (earlier it was 2.0.0.5).

    Then we started getting the import error as well as while publishing the ribbon workbench also same error.

    "The ribbon item 'ccs.Mscrm.SubGrid.ccs_account_holding.AdvMergeRecords.Hide' is dependent on ribbon control id='Mscrm.SubGrid.ccs_account_holding.AdvMergeRecords"

    Then we uninstalled the rollups(both 1 and 2) and trying to reimport same error we are facing.

    i replaced our custom  RibbondiffXML  to Vanilla CRM RibbondiffXML. Still facing the same issue :(


    • Edited by Roopa KN Tuesday, June 16, 2015 4:53 AM
    Tuesday, June 16, 2015 4:52 AM
  • Yes - it seems that the merge button was removed from the ribbon and so the Hide Action is now referencing it but the button is not there.

    I think the easiest way forward will be to create a new button in the ccs_account_holding entity SubGrid with and ID of Mscrm.SubGrid.ccs_account_holding.AdvMergeRecords - this should then allow you to remove the Hide Action - and then the button.

    Scott Durow
    Blog www.develop1.net    Follow Me
    Rockstar365
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Tuesday, June 16, 2015 10:18 AM
    Answerer
  • Same problem occured to me when i tried to add button to phone call.
    I forgot to add phonecall entity to solution, when I added phonecall to solution andexported it, customization.xml had new RibbonDiff field in:
    Entities->Entity (name = phone call) -> RibbonDiffXml,
    When I copy-pasted my code there, everything worked properly.
    Monday, June 22, 2015 9:54 AM