OCS R2 -> Mediation -> Audiocodes RRS feed

  • Question

  • Dear All,
    I have the following deployment:
    - OCS R2:
    - Mediation: NIC to OCS, NIC to Audiocodes GW:
    - Audiocodes 1000 Gateway (with a PSTN slot and a FXS one):

    Inbound and Outbound Calls work fine, however (in my opinion) I've an incorrect behavior for outbound calling.

    Steps to reproduce:
    - Dial a PSTN phone number from O.C. client

    What happens:
    - The call is served correctly, but, if I sniff the IP traffic between Mediation and the gateway, I see tcp sip packets going from to So it seems that the RTAudio flow goes into and, after the transcoding, goes out from again for going to Audiocodes Gateway. 

    Expected result:
    - The Audiocodes Gateway has to receive trancoded audio flow from the NIC that has the IP address

    Consider that:
    - I set the "TEL-> IP" routing table on my gateway in order to send incoming calls to and it works
    - That behaviour causes an error when a FXS phone tries to close a transfer to O.C. client

    Maybe I've a not correct configuration, but I checked several times the "Deploying Enterprise Voice" doc and it seems that everything is OK.

    Is there anyone who can help me to understand what is happening?
    Thank you
    Tuesday, September 8, 2009 9:14 AM

All replies

  • iwgroup,

    You should have your mediation server data and voice NICs on different subnets.  I'd recommend a new subnet specifically for the voice side with the mediation NIC (audiocodes side) and the audio codes on their own subnet.

    hope this helps

    Kevin Peters MCSE/MCSA/MCTS/CCNA/Security+ blog: www.ocsguy.com
    Tuesday, September 8, 2009 3:42 PM
  • Thank you Kevin.

    I will use your suggestion... but for now and for testing I prefer to enable only one NIC, I really appreciate your help (I don't know why Microsoft don't say anything on that).

    However the transfer error isn't solved, so I opened another thread http://social.microsoft.com/Forums/en-US/communicationsservertelephony/thread/6724683a-5d7e-4ed9-8463-af6cd9e80c6c

    Kind regards
    Wednesday, September 9, 2009 2:23 PM
  • Just a quick note.

    If you are using two NIC's on Mediation, make sure you disable the DNS registration on the NIC facing Audiocodes. (you might need to delete the existing DNS record for If you are using one NIC and adding second IP, disable DNS registration on the NIC and create static DNS entry for the IP address facing Front End server ONLY.


    Thursday, September 10, 2009 2:34 AM