locked
Customizing Quote and Order RRS feed

  • Question

  • Hi there,

    I have added a custom attribute with the same properties to both the Quote and Order entities.

    On 'Create Order' of the Quote it does not transfer the custom attribute value to the Order entity.

    Is there anything built in to do this, or do I have to write my own script?

    Thanks very much

    Joe 

    Wednesday, December 23, 2009 4:12 PM

Answers

  • Hi Joe,

    you need to map this attribute between two entities and it will automatically transfer ..

    to mape this attribute..go to settings --> customization --> custom entities --> open Quote Entity

    then select "1:N Relation ship" and Open Quote_Order Relationship..

    On this relationship form go to mappings and then click on New and then create mapping between quote and order for this new field..

    save and publish these changes and you are done!!

    Hope this helps..
    • Proposed as answer by Mayank Pujara Wednesday, December 23, 2009 4:22 PM
    • Marked as answer by Joe.com Wednesday, December 23, 2009 4:56 PM
    Wednesday, December 23, 2009 4:20 PM

All replies

  • Hi Joe,

    you need to map this attribute between two entities and it will automatically transfer ..

    to mape this attribute..go to settings --> customization --> custom entities --> open Quote Entity

    then select "1:N Relation ship" and Open Quote_Order Relationship..

    On this relationship form go to mappings and then click on New and then create mapping between quote and order for this new field..

    save and publish these changes and you are done!!

    Hope this helps..
    • Proposed as answer by Mayank Pujara Wednesday, December 23, 2009 4:22 PM
    • Marked as answer by Joe.com Wednesday, December 23, 2009 4:56 PM
    Wednesday, December 23, 2009 4:20 PM

  • You have to map these fields in the relationship "quote_ordes"

    Go to the Customization -> Entity quote -> In Details Relationship 1 to N fin the relationship "quote_ordes" and mapping these custom field.

    After that publish the entity and try again.

    Jimmy Larrauri
    Wednesday, December 23, 2009 4:21 PM
    Moderator
  • Brilliant!

    Thanks very much Jimmy.
    Wednesday, December 23, 2009 4:56 PM
  • You welcome
    Jimmy Larrauri
    Wednesday, December 23, 2009 5:00 PM
    Moderator
  • Superb!

    Thanks very much MayankP.

    Joe
    Thursday, December 24, 2009 9:34 AM