locked
Cannot Syncronize with the corporate address book

    Question

  •  

    Hello:

    I´m a little confuse with this issue, i have read some threadsin the forum but i haven´t found any solution for my case

    My Communicator server is W2003 Enterprise ed Sp2. is also a certificate server

    My Mail server is Exchange 2003.

     

    The problem is that i have no db files on clients i have the warning yellow signal at comunicator client saying that cannot sincronize with the global address book, this maybe cause proxy server setting at your web browser does not permit to access to the address book.

     

    It happens on clients xp and vista, with outlook 2007

     

    If i try https://OCS/abs/ext or /int i cannot see nothing

     

    I also don´t know how to get the galcontact.db

     

    On the OCS server abserver -regenur and abserver -syncnow run fine

     

    Any one can help me

     

    thanks

     

    Nacho

    Tuesday, October 7, 2008 3:14 PM

All replies

  • Are these clients connecting internally or externally (via Edge)?
    Tuesday, October 7, 2008 4:18 PM
    Moderator
  • The client downloads the addressbook from the Webserver component in OCS

    The client also uses the IE proxy settings and if your Webserver components FQDN is not an exception in your options then it will try to find it through the proxy server and probably it will not find it.

     

    So try to disable your proxy server settings and restart your communicator

     

    You must also have configured your IIS server to listen on HTTPS port by providing a certificate with the correct name in the certificate.  If you have a STD server then your current cert used for OCS is probably fine to use with IIS aswell

     

    Check the following directory on a STD OCS server to verify if the Addressbook files are there.

    C:\Program Files\Microsoft Office Communications Server 2007\Web Components\Address Book Files\Files

     

    Tuesday, October 7, 2008 4:21 PM
  • Clients are connecting OCS internally

     

    I have test to configure the IE in all possible options (Automatically detect, With out any mark at connection tab) adding these addresses at intranet sites

    http://OCS_Server_name

    https://OCS_Server_name

     

    IIS is configure to use SSL

     

    I saw at OCS in

    C:\Program Files\Microsoft Office Communications Server 2007\Web Components\Address Book Files\Files

     

    There are at least 30 files with extension LSABS y DABS. I don´t know if that is correct.

     

    I also have read that it could be a problem with the certificate.

    I tell you how is it going

     

    On the OCS in the IIS (default web site) is installed a certificate for OCS.MyCo.com which is public, but the client we connect using OCS.myLocaldomain.local This certificate is installed at OCS but not at IIS Default web site which cannot have more than 1 certificate installed This could be the cause? is bad configured

     

    Thxs

     

    Nacho

     

     

     

    Wednesday, October 8, 2008 1:42 PM
  • You address book files look fine so no problem there.

     

    Your Certificate in IIS must have the ocs.mylocaldomain.local in the certificate.

    The IIS website can only have one cert.  You can however create a new website for you public website and set another cert on there

    Or create a cert with the OCS certificate wizard and add SAN names in the certificate so that your cert has more than one name as OCS.MYco.com and ocs.mylocaldomain.local

     

    But keep in mind that you should not expose your OCS server to the internet.  You need to use a reverse proxy to do that and then you set the external name cert on your reverse proxy and you don't have to wory about the public name on your ocs server

     

    Wednesday, October 8, 2008 11:20 PM