locked
Error installing a new instance of MSCRM 4.0 "The instance name must be the same as computer name" RRS feed

  • Question

  • I am trying to install a new instance of CRM 4.0.

    CRM App Server Name - CRM01

    CRM DB Server Name - CRMDB (SQL Server 2008 R2)

    CRM DB Instance Name - CRMDB\Dev

    I get the error message "The instance name must be the same as computer name".

    I have tried the sp_dropserver and sp_addserver as many users have pointed out.

    The server name has never changed.

    In fact there was another instance of CRM installed on this same server but on a SQL Server 2005 instance.

    Now I am trying to install CRM on a SQLServer 2008 R2 instance.

    Any help will be greatly appreciated.

    Wednesday, September 9, 2015 11:58 PM

All replies

  • It's been sometime since I last did a CRM 4.0 installation, if you want to use SQL Server 2008 R2 you will need to install/slipstream server rollup 7 (at least) as part of the installation or the installation will fail. I believe that the newest CRM 4.0 installer included this package.

    Thursday, September 10, 2015 1:45 AM
  • What do you get if you run the following queries ?

    exec sp_helpserver
    go
    select @@servername
    go


    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Thursday, September 10, 2015 9:20 AM
    Moderator
  • Both return the same result "CRMDB\Dev".

    Thursday, September 10, 2015 10:27 PM
  • Any idea where I would find the new CRM 4.0 installer. The installer, that I am using is from 2008.

    Thursday, September 10, 2015 10:28 PM
  • To fix the issue you need to ensure that the query "SELECT @@ Servername" returns at least the machine name. f the select statement doesn't return the actual name of the machine you might consider the following steps:


    to query the binds 

    SELECT @@ Servername


    to drop the invalid name 

    Sp_dropserver 'OLD_SERVERNAME'


    to add the correct machine name 

    Sp_addserver 'ACTUAL_MACHINE_NAME',local 

    After you applied the changes, make sure to restart the SQL server instance and to re-run the CRM environment diagnostic check to proceed with the CRM 2011 Server setup.   


    Thank you, Sreeni Pavalla Please Vote as Helpful and Mark As Answer if it helped you. Blog: https://sreenipavalla.wordpress.com/

    Thursday, September 10, 2015 10:36 PM
  • The only place I can think that you may be able to get an updated iso is from MSDN.  They usually have the older software.


    Jason Peterson

    Thursday, September 10, 2015 11:02 PM
  • SELECT @@Servername returns CRMDB\Dev

    The name of the server is CRMDB

    I have tried sp_dropserver and sp_addserver to remove "CRMDB\Dev" and add "CRMDB". But I still get the same error.

    This server (CRMDB) also has a SQL Server 2005 instance that once hosted a CRM install.

    I have now added another 2008 R2 instance (name-CRMDB\Dev) and trying install CRM on a brand new App server (name-CRM01).


    **Note-I am trying to install CRM4.0**
    • Edited by MKU123 Friday, September 11, 2015 12:39 AM
    Friday, September 11, 2015 12:36 AM
  • This all looks correct. One quick sanity check - make sure you restart the SQL Server service after sp_addserver

    I'd suggest you use SQL Profiler to see what commands the Crm installer is executing when it throws the error, to see if that throws any light on the issue.

    Have you tried the IgnoreChecks registry key to allow you to install despite validation failures ?


    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Friday, September 11, 2015 8:56 AM
    Moderator
  • Good idea. I will try the profiler.

    I was looking for the IgnoreChecks registry key but since this is a new install, there is nothing in the registry yet.

    Friday, September 11, 2015 10:20 PM
  • The only thing that showed up in the profiler was @@SERVERNAME.

    Wednesday, September 16, 2015 2:55 AM
  • Well, nothing helped.

    Looks like CRM 4.0 has a problem installing on a named instance.

    Here is what I did to resolve the issue.

    1 - Installed CRM pointing to another SQL Server (default instance. non named)

    2 - Backed up the Config and Org databases

    3 - Restored the Config and Org databases on the named instance

    4 - Set the IgnoreChecks registry key to 1

    5 - Changed settings to point CRM to the new server(Follow https://support.microsoft.com/en-us/kb/952934)

    Thursday, September 17, 2015 11:27 PM