locked
Problems connection to CRM Online using Organisation accounts RRS feed

  • Question

  • Hi

    Microsoft have moved our online CRM to use Organisational accounts rather than Windows Live accounts overnight. Our customer portal, which is sat on top of XRM and is essentially the sample portal previously released through the MS Dynamics Community, is now broken. It worked fine yesterday.

    After a number of hours of solid investigation I am not really getting any nearer. The issue is PROBABLY to do with authentication although all this has been worked through to try and resolve this.

    The errors initially received were

     Exception Details: Microsoft.Xrm.Client.Services.Samples.DeviceRegistrationFailedException: DeviceAlreadyExists: 0x80041132

    After much investigation we rebuilt the app with the latest Microsoft.XRM.* dlls in the 2011 SDK, and also the latest version I could find (4.2) of the AntiXSSLibrary dll. This has had some effect, since the error is now different!


    Exception Details: System.ServiceModel.FaultException: ACS10002: An error occurred while processing the SOAP body. ACS50012: Authentication failed.
    Trace ID: ed0925a6-11e9-463a-8ed6-83e8f6d23ae0
    Timestamp: 2014-02-28 12:46:54Z

    I am of course continuing to investigate and try and understand, and thus resolve, this, but if anyone has some knowledge or helpful suggestions that would point me in a particular direction that would be much appreciated.

    Many thanks in anticipation

    Gavin Clark

    This issue has now been resolved. We achieved this by finding the version of the Dynamics CRM SDK that was released around 19 Dec 2013, and rebuilding with this

    Friday, February 28, 2014 1:02 PM