off topic - Wireless Printer Sharing RRS feed

  • General discussion

  • I have 2 Gateway Computers both w/WindowsVistaXL.  The desktop is wired to a Brother DCP 7020 Laser Printer. I have a Netgear Router set-up so I can use the Laptop Wireless. Everything works great, I can go on the Internet w/no problem. In fact, I can do everything but print.  The Netgear people told me I have to go into the system & set up to enable File & Printer Sharing which I do not know how to do.  I have hooked the laptop up to printer & installed the above printer CD on the laptop but when I unplugged the printer from the laptop & back to the desktop, I am unable to do wireless printing from the laptop.  Please help me!  I have been trying to work on this problem all weekend.  Connie B.

    Monday, March 31, 2008 2:40 AM

All replies

  • Connie, I assume that you are not using Windows Live OneCare, so you're off topic for this forum.

    However, to enable File and Printer Sharing and then share that printer in Vista, you will need to do the following:



    On both computers, go to Control Panel, and click on Network and Sharing Center.

    Your network will be shown in this panel, with lots of options below.

    Make sure that your network is identified as a Private Network. If it shows Unknown or Public, click on Customize, and change it to Private.

    Once you have changed this, scroll down and you will see a line that says Printer Sharing. Click the circle to the right of that line with the down arrows in it.

    Select turn on Printer Sharing and click Apply.

    Accept the UAC prompt and login with an admin password if it prompts for this.


    On the PC that the printer is physically attached to, select Printer in Control Panel.

    Select the Printer that is shown as attached and ready, matching your Brother DCP 7020.

    Right click the printer and select Sharing.

    Select the option to share the printer and give it a name.


    On the laptop that you want to print from to the printer hosted on the other PC, select Printers in Control Panel and then add a printer.

    Select network printer and your Brother should appear on the list.



    Monday, March 31, 2008 2:54 PM