locked
CRM 2011 early bound classes proxy issue RRS feed

  • Question

  • Hi All,

     

    I've generated a early bound class that includes all of my custom entities, enums, etc.

    I'm using a OrganizationServiceProxy class to connect to my organization.svc.

    I'm using the early bound classes within a console application.

     

    I step into the code and view some of the entity sets via the watch window and all are errors, following that 1st FileNotFound error, all the rest are ArgumentExceptions?

     

    Also, this works within the plugin context and within a completely separately web service and it works fine from both. 

    Any ideas?

    Thanks

    Jon

    Thursday, November 17, 2011 10:07 PM

Answers

  • Something must have gotten out of sync.

     

    We regenerated it and it is working now.

     

    Thanks

    • Marked as answer by Goosey314159 Monday, November 21, 2011 7:51 PM
    Monday, November 21, 2011 7:51 PM

All replies

  • To use the early binds , you need to enable proxy type behaviour

    _serviceProxy.ServiceConfiguration.CurrentServiceEndpoint.Behaviors.Add(

    new ProxyTypesBehavior());

    or

    _serviceProxy.EnableProxyTypes();

     

    I hope this helps.



    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer". Amreek Singh Senior CRM Consultant CDC Praxa Sydney, Australia http://mscrmshop.blogspot.com http://crm2011usersettings.codeplex.com
    • Proposed as answer by Amreek Singh Friday, November 18, 2011 2:40 AM
    Friday, November 18, 2011 2:40 AM
  • Something must have gotten out of sync.

     

    We regenerated it and it is working now.

     

    Thanks

    • Marked as answer by Goosey314159 Monday, November 21, 2011 7:51 PM
    Monday, November 21, 2011 7:51 PM