none
CSS and JS files not loading after I copied my MVC5 project from one system to another. RRS feed

  • Question

  • I am working on an MVC5 Web Application and I was building it on my PC (running on windows 7) using Visual Studio 2013 and it is working fine there but when I copied the project to my laptop (running on windows 10) the css and js files and all the images would not load and it keeps throwing the error 'Failed to load resource: the server responded with a status of 500 (Internal Server Error)'. I tried cleaning the project and rebuilding, changing port numbers and adding links of js and css files in the layout page instead of bundling them, but nothing seems to work.
    Sunday, June 4, 2017 5:18 PM

All replies

  • Hi Rida, 

    You are welcome to MSDN forum. 

    However this issue is more related to ASP.net web issue which has its own forum for this: 

    https://forums.asp.net/1146.aspx/1?MVC

    Anyway, I got similar thread for you to refer:

    https://stackoverflow.com/questions/10512053/css-images-js-not-loading-in-iis

    As it could be caused by iis setting, you may refer to the most vote reply from Matt. And another possibility is the window permissions issue.  

    I really hope it could help.

    Best regards, 

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    • Edited by Fletch Zhou Monday, June 5, 2017 8:39 AM
    • Proposed as answer by Fletch Zhou Thursday, June 8, 2017 12:50 PM
    Monday, June 5, 2017 8:39 AM