locked
External User unable to access CRM (On Premises) RRS feed

  • Question

  • Good morning all,

    I have a bit of a weird one for you...

    One of our users out in the field cannot access CRM.  When she goes onto the webpage for our CRM server, she gets a log in prompt.  She puts in her domain login and password and is confronted with a grey screen.  The usual CRM left hand toolbar and ribbons do not appear.  The Dynamics logo appears in the totle bar.

    When I remote in to her machine and use my login for CRM, I get the same.

    However, when I direct her browser to the mobile site, it loads fully and she is able to view and edit her leads and opportunities.

    She is using IE 11, with all active x and java settings enabled correctly.


    Mike Oke MCTS, MCITP (Windows 7)

    Wednesday, December 11, 2013 10:24 AM

All replies

  • Mike, 

    This can be related to Internet Explorer 11 which is not working correctly with CRM 2011 (which probably you're using). Please add CRM server to trusted site and compatibility sites or use trick

    http://nzregs.wordpress.com/2013/07/02/accessing-crm-2011-in-internet-explorer-11-windows-8-1/

    Let us know if that helped.

    KG


    My Dynamics CRM Blog: http://bovoweb.blogspot.com

    Wednesday, December 11, 2013 11:21 AM
  • Hi KG.

    The user is on Win-7 not 8...  I have already added our URL to the trusted sites and tried compatibility settings (first things I did).  I have also tried using both Chrome and Firefox and get the same results when accessing the explicit URL of our CRM deployment.

    I probably should have been clearer that the  mobile app is not automatically displayed when browsing to the CRM address.  Rather, it browsed to the main site.  The only reason I found out the mobile express site works is I browsed there as a matter of troubleshooting protocol when trying all the alternate URLs for the server (to see if auth.xxx or dev.xxx had a better outcome).


    Mike Oke MCTS, MCITP (Windows 7)

    Wednesday, December 11, 2013 11:45 AM
  • Is it happening only on specific user/computer ? You can have a look at Event Viewer on CRM server or even IIS logs if communication with user/computer is correct.

    KG



    My Dynamics CRM Blog: http://bovoweb.blogspot.com

    Wednesday, December 11, 2013 11:50 AM
  • Hi KG,

    Looking on event viewer, I can't see any errors or warnings which would indicate an issue relating to a user.

    It's happening on one specific user's machine.  The only major difference between her and other users is that they all use do main laptops in the field.  She uses her own PC on the default workgroup...  I'm wondering if that may be the issue.


    Mike Oke MCTS, MCITP (Windows 7)

    Wednesday, December 11, 2013 2:31 PM
  • Mike,

    Yes, it may have an impact. If you have access to problematic computer you can trace session using Fiddler. 

    KG


    My Dynamics CRM Blog: http://bovoweb.blogspot.com

    Thursday, December 12, 2013 10:51 AM