locked
The timeout period elapsed prior to completion of the operation or the server is not responding. RRS feed

  • Question

  • Hi,

    After publishing a simple customization of two fields i come cross with this issue where i cannot access the concerned organization

    tried to troubleshoot by changing web-config :-  <httpRuntime executionTimeout="3600" maxRequestLength="20000"/>

    and mscrmservices directory <httpRuntime maxRequestLength="20000"/> without success..

                                                                             

    Wednesday, April 25, 2012 6:01 AM

Answers

  •  we have solved by restarting the DB server in weekend strange thing only needed to have re-start.

    • Marked as answer by 2Day Tuesday, May 1, 2012 8:35 AM
    Tuesday, May 1, 2012 8:35 AM

All replies

  • Hi,

    By only looking at above, it is very difficult to find the root cause.

    I am assuming you would have recycled the application pool or reset IIS and now you can access the ORG.

    It could be that your SQL Server was not responsive when you tried to publish the changes (even though minor).

    I hope this helps. If my response answered your question, please mark the response as an answer and also vote as helpful.


    Ashish Mahajan, CRM Developer, CSG (Melbourne)
    My Personal Website: http://www.ashishmahajan.com
    My Blogs: http://ashishmahajancrm.blogspot.com.au and http://ashishmahajancrm.wordpress.com
    My Youtube Channel: http://www.youtube.com/user/ashishmahajanmscrm

    My Linkedin: View Ashish Mahajan's profile on LinkedIn
    My Twitter: https://twitter.com/#!/ashishmahajan74

    Wednesday, April 25, 2012 6:38 AM
  • The above errors shows that you are experiencing a problem connecting to your SQL Server DB server from any remote machine in your network, Please make sure of the following:
    1) You are able to ping the machine from the remote server.
    2) Try to connect make sure that the SQL Server Engine service is up and running, You can open "SQL Server Configuration Manager" and make sure that the service is up and running.
    3) Make sure that you have at least one protocol TCP/IP,Named Piper or Shared Memory is allowed on both your client and your DB Server and this you can check it from SQL Configuration Manager.
    4) THIS FIXED MY PROBLEM: Disable the Domain firewall in the DB machine that blocks all inbound connections to your DB Server. To do this:
    a) From Server Manager.
    b) Under Configuration - > Select Windows Firewall.
    c) Click on Windows Firewall Properties and disable your domain profile firewall.

    Try to refresh your page and you will be able to connect to your DB.

    And also add following registry keys to HKLM\Sofware\Microsoft\MSCRM folder and this resolved this problem.

    DWORD OLEDBTimeout = 300000 (decimal)
    DWORD ExtendedTimeout = 1000000 (decimal)
    DWORD NormalTimeout = 1000000 (decimal)



    I hope this helps. If my response answered your question, please mark the response as an answer and also vote as helpful.
    Mubasher Sharif
    Check out my about.me profile!
    http://mubashersharif.blogspot.com
    Linked-In Profile
    Follow me on Twitter!




    • Edited by MubasherSharif Wednesday, April 25, 2012 6:51 AM
    • Proposed as answer by MubasherSharif Wednesday, April 25, 2012 7:05 AM
    • Unproposed as answer by 2Day Wednesday, April 25, 2012 8:36 AM
    Wednesday, April 25, 2012 6:41 AM
  • The error message indicates a SQL Server timeout. This is controlled via the OLEDBTimeout registry value (as described at http://mscrmuk.blogspot.co.uk/2008/09/sql-timeouts-in-crm-generic-sql-error.html ), in addition to the web.config settings (which relate to timeouts for web service requests)

    Microsoft CRM MVP - http://mscrmuk.blogspot.com  http://www.excitation.co.uk


    Wednesday, April 25, 2012 6:49 AM
    Moderator
  • it is related only One Org. this an Enterprise MS CRM 4.0 all other Org are working , already have doubt about OLEDBTtimeout registry but documents are pointing it as unsupported method. 

    Wednesday, April 25, 2012 7:16 AM
  •  we have solved by restarting the DB server in weekend strange thing only needed to have re-start.

    • Marked as answer by 2Day Tuesday, May 1, 2012 8:35 AM
    Tuesday, May 1, 2012 8:35 AM