locked
import products via csv CRM 4 RRS feed

  • Question

  •  

    Hello
    I have been tring upload new products
    via a csv file using the import functions in crm4


    does not seem to be working I get a non existing entity error messege here is the text in my csv

     

    product name,ID,currencie,salesunit,defaultunit,decimals
    CRMprod1,CRM-CA-PRO,"transactioncurrencies,{F425745A-67EF-DC11-9FB3-00104BD27F1C}","uomschedule,{7C1BA26A-47FD-DB11-A8E4-00104BD27F1C}","uom,{7D1BA26A-47FD-DB11-A8E4-00104BD27F1C}",2

     

    does anyone have an Idea?
    I am using a crm 4 upgraded italian version upgraded with the trial italian version I could see quite a few bugs.


    BR
    Claudio

    Tuesday, March 18, 2008 6:38 AM

Answers

  • If your columns on your CSV match the columns in CRM, the import utility should do this automatically.  Why are you importing guids?  I have found that it is pretty smart defining lookup fields from the name, and that guid is not required like it was with 3.0.

     

    If you need to transform the data during import or schedule imports, you will want to use Scribe Insight.

    Tuesday, March 18, 2008 10:58 AM
    Moderator
  •  

    Hello
    I have finally run my test
    and the probblem resides in the upgrade, evidentily there are still a few bugs with the upgrade process, the import functions do not work correctly, in an upgraded CRM 3 to 4. for what concerns the the exchange rate probleme it looks like forcing all the user settings to use the comma as decimal separator does the trick.

    BR Claudio

    Friday, March 21, 2008 9:54 AM

All replies

  • If your columns on your CSV match the columns in CRM, the import utility should do this automatically.  Why are you importing guids?  I have found that it is pretty smart defining lookup fields from the name, and that guid is not required like it was with 3.0.

     

    If you need to transform the data during import or schedule imports, you will want to use Scribe Insight.

    Tuesday, March 18, 2008 10:58 AM
    Moderator
  • Hello Joel,
    I was trying to import new products I have mached the columns but the lookup fields with the name or with the guids is not beein recognized
    this is not working :

    product name,ID,currencie,salesunit,defaultunit,decimals
    CRMprod1,CRM-CA-PRO,"transactioncurrencies,euro","uomschedule,nro","uom,nro",2

    nor is this

    product name,ID,currencie,salesunit,defaultunit,decimals
    CRMprod1,CRM-CA-PRO,euro,nro,nro,2

     

    have you any Idea why?
    I am not transforming any data but just trying to get new data in the CRM

    BR
    Claudio

     

     

    Tuesday, March 18, 2008 11:57 AM
  •  

    I'm not sure what is causing your problem.  How are you creating your CSV file?  I have had the most success creating it in Excel and saving to CSV format, not so much in just creating a text file.

     

    Tuesday, March 18, 2008 12:54 PM
    Moderator
  •  

    Hello Joel,
    first of all thanks for your replies. The systems looks has it is actually accepting the file
    it is this : "transactioncurrencies,euro" or euro that it doesnt like and tells me that the data is not in the format it is expecting, then when I use a format "entityname,GUID" but it then tells me that no entity was found

    I am quite sure the the guid and the names aare correct, but I must say I am tring this on a CRM 4 tha is the result of an upgrade from crm 3 server in Italian and I have noticed a bunch of problems that come out, and functions that are not working correctly.
    (like euro exchagne rate value is set to 1000000 and the is no way I can change it)

    I will be trying on a clen crm 4 install and see if this is working.             

    I will let you know.
    BR
    Claudio

    Tuesday, March 18, 2008 6:10 PM
  •  

    Hello
    I have finally run my test
    and the probblem resides in the upgrade, evidentily there are still a few bugs with the upgrade process, the import functions do not work correctly, in an upgraded CRM 3 to 4. for what concerns the the exchange rate probleme it looks like forcing all the user settings to use the comma as decimal separator does the trick.

    BR Claudio

    Friday, March 21, 2008 9:54 AM
  • Hi all,

     

    I am trying to import opportunities from a CSV file into CRM 4.0 and I can t get it working :-(

     

    The problem has to to with the currency which is a mandantory field. I tried several formats: EUR, EURO, the GUID which is {99B651BA-55F3-DC11-B2E4-404E57434431}, "currency,{99B651BA-55F3-DC11-B2E4-404E57434431}"

    Nothing works - I always get the error "the source data is in the wrong format" (translated from german).

     

    Any idea would be great!

     

    thanks and regards

      Holger

     

     

    Wednesday, April 16, 2008 9:21 AM