locked
How do you delete the Windows OneCare Backup under Windows 7? RRS feed

  • Question

  • The old Stephen Boots answer is obsolete, so stop pointing people to it and remove it from the FAQ.  No method described there works in Windows 7.  You need to assign someone to update the solution to this problem.

    - you can't run OneCare to adjust or do a final backup, since it does not run in Win7
    - you can't run CACLS, it just tells you it is obsolete and to use icacls
    - icacls help text is exceptionally verbose and useless gobledegook.  When it gets that complicated you guys should write UI to manage it.  There is no way I can guess what it means, and no way I'm going to risk the consequences of a mistake.  I've already got incomprehensible ACL trouble, I don't want to risk making it worse.

    Win7 nuked OneCare, sadly.  The least Win7 could do is have a simple way to nuke the 400GB of backup it now wasts on my external drive so I can start again.
    Sunday, November 29, 2009 10:48 PM

Answers

  • Those FAQs were never meant for Windows 7 but some of the methods will work. The easy way to delete the old backups is to copy any data on the external drive to your computer, format the external drive, then copy the saved data back.
    Jim - MVP Windows Live - Forum Moderator - Live One Care - Live Mesh - Microsoft Security Essentials
    • Marked as answer by TanjB Monday, November 30, 2009 5:17 AM
    Monday, November 30, 2009 4:28 AM
    Moderator

All replies

  • Those FAQs were never meant for Windows 7 but some of the methods will work. The easy way to delete the old backups is to copy any data on the external drive to your computer, format the external drive, then copy the saved data back.
    Jim - MVP Windows Live - Forum Moderator - Live One Care - Live Mesh - Microsoft Security Essentials
    • Marked as answer by TanjB Monday, November 30, 2009 5:17 AM
    Monday, November 30, 2009 4:28 AM
    Moderator
  • OK, I've got one computer with enough spare disk to do that.  Not as easy as a delete should be, but at least feasible.
    Thanks!

    Monday, November 30, 2009 5:17 AM
  • OK, I've got one computer with enough spare disk to do that.  Not as easy as a delete should be, but at least feasible.
    Thanks!

     
    OK...but I haven't. I need to delete a large One Care Backup file which is on an external hard drive. My laptop runs windows 7.

    Surely this isn't a big deal?
    Thursday, December 10, 2009 2:01 PM

  • OK...but I haven't. I need to delete a large One Care Backup file which is on an external hard drive. My laptop runs windows 7.

    Surely this isn't a big deal?

    This procedure should work perfectly well in Windows 7:

    Delete a backup set folder from an external hard disk in Windows Vista

    1. On the taskbar, click Start. In the Start Search box, type explorer.exe, and then press ENTER.
    2. Under Computer, double-click the disk letter that corresponds to your external hard disk.
    3. Right-click the Windows Live OneCare folder, and then click Properties.
    4. On the Security tab, under Groups or user names, click either Administrators or your user name.
    5. Next to Full Control, select the Allow check box, and then click Apply.
    6. In the Windows Live OneCare folder, select the backup set folder, and then press DELETE.

    -steve


    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Friday, December 11, 2009 2:11 PM
    Moderator
  • I tried this but everytime I pressed Delete it tells me "You are require permission (mycomputer's name/my name) to make changes to this folder." that means I need to get permission from the Administrator even though I AM the Administrator!! So how do I do that so that it recognizes me as the administrator?
    Saturday, December 12, 2009 3:17 AM
  • Maybe it should work .. but it doesn't.  Step 6 does not in fact delete the file.  Even logged in as administrator.  Even saying yes to the UAC, or going in through an Administrator CMD window.  Something about the ACLs refuses to let it happen.  Probably it would work if one could change the ACLs but I can't fathom the screens of gobbledegook which the new icacls gives as "help".  Looks like RMinden is hitting the same problem I had.

    Anyway, I followed Jim's advice and did it the long way around.  Save everything else, nuke the disk, rebuild it.
    Sunday, December 13, 2009 6:02 AM
  • I found no direct solution.  Followed Jim's advice: save everything else to a system which had enough spare space, then reformat the drive.  Slow, but most of it can run unattended.
    Sunday, December 13, 2009 6:04 AM
  • Formatting, though extreme, is the best way to cleanup the drive.
    However, to address the permissions issue, what I've found is that you can apply the permissions at the top level of the backup folder and include the sub-folders, but then to delete the backup files, you may need to start at the lowest level within the folder. Delete the contents of the folder, then delete the folder, working your way up to the top.
    Another option is to contact support for help with the removal of the folder and its contents:
     

    How to reach support (FAQ) - http://social.microsoft.com/Forums/en-US/onecareinstallandactivate/thread/30400b52-7f26-4ba0-bc18-17e305329d90




    -steve


    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Monday, December 14, 2009 12:54 PM
    Moderator
  • After much of a frustrating effort, I was able to delete the ONECARE backup file with Win7 in the following manner:

    Using Windows Explorer open up the ONECARE folder and any sub-folders under the main

    go to the lowest sub-folder and change the permissions in my case " EVERYONE " to " full file control"

    select the files and delete them

    select the sub-folder and delete it

    Go to the next lowest sub-folder and repeat from the change of permissions and work your way backwards up to the root folder

    BTW, this was 40+Gig of data

      

     

    Wednesday, August 4, 2010 3:36 AM