File mod/create date issues with synctoy RRS feed

  • Question

  • There are still some very serious bugs with Synctoy 2.1 that are keeping me from using it effectively, all related to how synctoy compares dates.

    Let's say I have a network with Computers A (local) and B (network), both running Vista Home Premium x64, and NAS X (Ubuntu 9.10).  Now put a file on the desktop.  Copy that file manually to all three locations where I want the file.  On Computer A, the file copies with the same create/modified dates as the desktop version.  NAS X also copies with the same dates.  Computer B, however, has a more modern created on date, with the same modifed date.  What happens now is that sync on both machines will assume the file on B is newer since the modified date is the same, but the created date is not.

    It gets stranger.  I set up Computer A and B each to Contribute to NAS X (Left Computer A/B, Right NAS X), and Echo NAS X to Computer A/B (Left NAS X, Right Computer A/B).  The reason I might want this over a traditional sync is simple: I want a master backup without a need to worry about a family member accidentally deleting something important, but I want to be able to filter file deletions throughout both (or more) machines without having to go to each machine.  Here's where things start to get strange, especially if I copy any files manually over the network.

    Normally, if I run a Contribute, then receive an echo, I wouldn't want a file I deleted off the server to reappear.  But in some cases it can happen very easily.  If I just ran a contrib/echo cycle and obtain "new data" files over the network, Windows will keep the original Modified date, but the Creation date is changed to whatever the current date/time is because the file is new to the system.  Now, the files on the computer and the network are identical, EXCEPT that the creation date is now NEWER on the Windows machine.  So, next time I run a Contrib/Echo cycle, it will update the file on the server to the newer date.  However, if I delete the file off the network server, Synctoy only knows that File X with create and modified dates Y and Z was deleted.  So, it seems to look at the local file, and during the next Contrib/Echo cycle puts the file back onto the server.  However, if I manually run ONLY an echo cycle, it will instead delete the local file.

    While it's arguably better to have saved extraneous data instead of losing it, it still created a ton of headaches when trying to do this automatically.  It seems that a lot of this is caused because Synctoy apparently compares Created dates.  This really should be an option, not a default as it causes unexpected behavior.

    Wednesday, September 1, 2010 1:15 AM