locked
Project Server 2010 - redirect root site URL to Project Web App (PWA) site RRS feed

  • Question

  • Hello

    I think to follow the best practice for project server 2010 site structure,  I created a root site collection http://projserv on my SharePoint 2010 web application "/" and then I provisioned PWA (project server web app) site under this root site.   the URL to PWA  is http://projserv/pwa   just as recommended.

    Everything work fine for project server so far..  but now I like to find way to redirect so when users browse to http://projserv  ,  they will be automatically redirect to http://projserv/pwa  (just to save users one step from going to the root site then to pwa as for them it is anoying)

    I tried to change HTTP redirect property in IIS at the web application site (where the root site is)  and reset IIS.   So far, redirect is not working.... as i hope it to.

    Anyone have any suggestion or what else i need to do here to make it redirect for project server...

    Thanks

     

     

     

     

     


    Swanl
    Thursday, December 8, 2011 5:37 PM

Answers

  • Add a Content Editor Webpart to the root site default page with the below code:

    <script type="text/javascript">

    _spBodyOnLoadFunctionNames.push("Redirecttopwa");
    function Redirecttopwa(){
      window.location.href = "/pwa";
    }

    </script>


    pratap
    • Marked as answer by swanl98 Wednesday, December 14, 2011 4:02 PM
    Wednesday, December 14, 2011 1:32 PM

All replies

  • Add a Content Editor Webpart to the root site default page with the below code:

    <script type="text/javascript">

    _spBodyOnLoadFunctionNames.push("Redirecttopwa");
    function Redirecttopwa(){
      window.location.href = "/pwa";
    }

    </script>


    pratap
    • Marked as answer by swanl98 Wednesday, December 14, 2011 4:02 PM
    Wednesday, December 14, 2011 1:32 PM
  • Pratap

    Thanks that what it is so easy.  My head must be heavy that i didn't think of that as a solution.  I tried to do it the hard way.

    Swanl

     

     


    Swanl
    Wednesday, December 14, 2011 4:02 PM
  • Hi there,

    I came up with the same problem and have an another solution to offer, to be done on IIS side.

    Instead of using a regular Http Redirect setting, you could use the URL Rewrite option, still in IIS Manager.

    Then you would choose the following settings:

    Then for the Redirect Url you need to choose: http://yoursite/pwa

    It worked for me. Hope it could help

    Tuesday, July 24, 2012 2:16 PM
  • Oliveee

    Thanks for your suggestion.  URL Rewrite is an extended option and I will need installed on my test server to test it out.

    Swanl


    Swanl

    Tuesday, July 24, 2012 4:20 PM