locked
Media Library private RRS feed

  • Question

  • Hey!

    How can i put The media library private ?

    each user has its own library

     

    thanks

    Thursday, August 25, 2011 11:24 PM

All replies

  • Not sure I actually understand the question but:

    • If you are talking about streaming to a DNLA device, you can't give specific users different access (part of DNLA specification).
    • You can create folders for specific users to put their media in that only they have access to - it will not stream though so you would need to say point your media device to their specific folder and add their credentials.

    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Thursday, August 25, 2011 11:50 PM
  • When I create a new user to access via browser the Home server, he can see media library of other users and I don't want that to happen, I've already removed permissions from the shared folders but the problem wasn't solved.
    Friday, August 26, 2011 12:12 AM
  • Has your server joined a Windows 7 HomeGroup? If so, those permissions override individual server folder permissions - if so disconnect the server from your HomeGroup.
    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Friday, August 26, 2011 12:19 AM
  • No :s
    Friday, August 26, 2011 12:32 AM
  • If you turn on media streaming, then any device capable of connecting to your server as a client can see all the media in all folders that are selected for streaming. There's no way to change this, I'm afraid, so if you don't want users to be able to see and stream each others' media, you'll have to turn off streaming entirely.
    I'm not on the WHS team, I just post a lot. :)
    Friday, August 26, 2011 12:51 AM
  • Is it a bug ? I don't think it has a reason for it to happen , if a user is different than the other and if we deny the access to the images why is the user going to have access to them on media library ?
    Friday, August 26, 2011 1:07 AM
  • As I said above, the DNLA Specification, to which WHS2011 is compliant, does not allow what you want to do. You will need to switch off streaming or put the pictures you don't want others to see in a separate folder which is not streamed.
    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Friday, August 26, 2011 1:11 AM
  • Is it a bug ? I don't think it has a reason for it to happen , if a user is different than the other and if we deny the access to the images why is the user going to have access to them on media library ?
    No, it's not a bug. It works this way by design.
    I'm not on the WHS team, I just post a lot. :)
    Friday, August 26, 2011 1:31 AM