locked
HPC 2008 R2 Diagnostics not working: 'The system cannot find the path specified' reported creating the task RRS feed

  • Question

  • I am trying to figure out why HPC will not let me run any Diag tests or jobs. I will constantly get the below error no matter what job I run:

    Pre Step run failed due to  : Error from node: [head node]:Exception 'The system cannot find the path specified' reported creating the task

    I think it could be something to do with Environment variables but they seem to be correct:

    CCP_DATA=C:\Program Files\Microsoft HPC Pack 2008 R2\Data
    CCP_HOME=C:\Program Files\Microsoft HPC Pack 2008 R2
    CCP_JOBTEMPLATE=Default
    CCP_SCHEDULER=headnode (actually shows physical server name which I have changed to headnode for this post)

    I have installed all the latest Service packs and is now version 3.3.3950.0

    I wish I could supply more information about the error, but the above is all I am given. Any assistance would be greatly appreciated.

    Mike.

    Thursday, March 1, 2012 5:44 PM

Answers

  • Well in the end, this turned out to be quite a simple fix. The Environment variables did not have the backslash at the end of each directory.
    • Marked as answer by Sekim79 Tuesday, March 6, 2012 1:59 PM
    Tuesday, March 6, 2012 1:59 PM

All replies

  • Hello.

    Could you please give any errors from Event Viewer (Applicatons and Services Logs -> Microsoft -> HpcServer)? Please copy and paste them . 


    Friday, March 2, 2012 11:12 AM
  • Hi,

    Thanks for your response, I checked out the Event logs and the only noticeable errors are the exact same error that is listed above.

    I have also scheduled a WebEx with a vendor that is a HPC Expert for Monday so will see what they can figure out. thanks.

    Here is one example of many:

    System
    - Provider
    [ Name] Microsoft-HPC-Scheduler
    [ Guid] {5B169E40-A3C7-4419-A919-87CD93F2964D}
    EventID 6
    Version 0
    Level 3
    Task 2
    Opcode 0
    Keywords 0x8000000000000000
    - TimeCreated
    [ SystemTime] 2012-03-02T13:58:09.103574600Z
    EventRecordID 1797
    Correlation
    - Execution
    [ ProcessID] 2140
    [ ThreadID] 2816
    Channel Microsoft-HPC-Scheduler/Operational
    Computer
    - Security
    [ UserID] S-1-5-18
    - EventData
    String [RemotingCommunicator] Start job and task 292.256 failed on node HEADNODE. Error: Exception 'The system cannot find the path specified' reported creating the task.
    Friday, March 2, 2012 10:02 PM
  • Well in the end, this turned out to be quite a simple fix. The Environment variables did not have the backslash at the end of each directory.
    • Marked as answer by Sekim79 Tuesday, March 6, 2012 1:59 PM
    Tuesday, March 6, 2012 1:59 PM