locked
Running CRM 2011 Email Router on computer outside of domain via IFD RRS feed

  • Question

  • This may not be possible, but I'm going to ask anyway.

    We host CRM over IFD and have a client that is interested in running their own copy of the email router, in the same way the email router could be configured to run for a CRM Online deployment. Obviously this computer will not be on the same domain as CRM, nor can its host machine be added to the correct group in AD.

    I've installed the router in a test environment and can connect to the server but when I load data from the CRM server it comes up blank even though I have the users configured to use the Email Router in the user options in CRM.

    I'm guessing that either the router can't authenticate through ADFS, or that not being able to add the machine account to the Priv User Group in AD is keeping it from reading the list, and running an external email router is possible on CRM Online because it uses windows live to authenticate.

    Before I sink any more time in this, does anyone know if what I am attempting is possible? Better still, has anyone had any luck with it?

    Thanks

    Rob


    • Edited by Rob Landolt Thursday, August 16, 2012 3:23 PM
    Thursday, August 16, 2012 3:22 PM

All replies

  • You are right. it's different from CRM Online since the authentication method is different. I don't think it's a supported configuration to put the email router outside the domain, since the email router machine account should be added into the PrivUser Group, if it's outside the domain, you cannot add it.


    Jackie Chen, Microsoft Online Community Support. Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, January 2, 2013 8:19 AM
  • What credentials are you supplying on the Deployment Tab in the Email Router configuration tool? Is this user a CRM user with system admin role in CRM?

    Have you verified that all users email addresses have been approved in CRM? If they have not been approved this would cause the list to come up blank.

    Have you verified that you have default Profiles setup for your Deployment on the Deployment Tab?

    If it was permissions issue I would think you would receive an error.

    Monday, January 7, 2013 3:41 PM
  • You can setup the Email Router from an external server using IFD authentication.  Make sure you select 'An online service provider' in your Deployment settings:

    The Domain User specified in the Access Credentials section must then be added to the PrivUserGroup {00000000-0000-0000-000000000000} Domain Group in Active Directory.


    --pogo (pat) @ pogo69.wordpress.com

    Tuesday, January 8, 2013 2:01 AM