locked
Custom Project fields not appearing in MSP_Timesheetline_UserViewCF RRS feed

  • Question

  • Created custom enterprise fields in MS Project 2010 and would like to use SQL Reporting to generate a report with data from these fields. According to Microsoft, any custom fields added are populated in this table for reporting purposes once data is saved, per this article: http://msdn.microsoft.com/en-us/library/ee767688.aspx

    We have entered data in the fields, saved, sent and approved the timesheet, yet none are appearing in the table itself.


    Moss_AZ

    Friday, April 27, 2012 10:25 PM

Answers

  • Hi Moss_AZ--

    Did you verify that reporting Timesheet jobs (save/update) is successful in PWA> Server settings> Manage Queue? Try updating the timesheet again & verify the queue jobs.

    Is this is successful, the data should get updated in Reporting database & _UserView of timesheet should get the data.

    Here is an excellent  sample by Christophe,
    http://blogs.msdn.com/b/chrisfie/archive/2010/04/06/project-server-2010-timesheet-custom-fields.aspx


    Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    • Marked as answer by MOSS_AZ Tuesday, May 1, 2012 11:39 PM
    Monday, April 30, 2012 10:51 AM

All replies

  • Hi Moss_AZ--

    Did you verify that reporting Timesheet jobs (save/update) is successful in PWA> Server settings> Manage Queue? Try updating the timesheet again & verify the queue jobs.

    Is this is successful, the data should get updated in Reporting database & _UserView of timesheet should get the data.

    Here is an excellent  sample by Christophe,
    http://blogs.msdn.com/b/chrisfie/archive/2010/04/06/project-server-2010-timesheet-custom-fields.aspx


    Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    • Marked as answer by MOSS_AZ Tuesday, May 1, 2012 11:39 PM
    Monday, April 30, 2012 10:51 AM
  • Thanks, that link helped. I think the key was to make sure I was in the custom timesheet view when submitting the timesheet. I also noticed in the queue there was a failed job due to a problem with a custom field.

    Moss_AZ


    • Edited by MOSS_AZ Tuesday, May 1, 2012 11:40 PM
    Tuesday, May 1, 2012 11:40 PM