Zentity Pivot Collection Error RRS feed

  • Question

  • Hi,

    I am currently doing the Getting started document  and when i run PublishingConfigService.ps1 i did not see the function Crete-ZentityCxmlFromResourceType. As a result when i reach step 5 to create collection, it could not recognise the command. Then when i go to Dashboard i could not see any collection being created.

    Wonder is it something wrong with my installation or configuration?

    Friday, July 8, 2011 8:53 AM

All replies

  • Hi,

    Thanks for your post.

    Try again with the following options:-

    Script to be loaded is:-

    Ø  PublishingService.ps1


    Command to create Collection is:-

    Ø  Create-ZentityPivotCollectionFromResourceType <ModelName> <ResourceTypeName>

     Please refer page number 8 in the Getting started guide.



    • Proposed as answer by Kalnemi Friday, July 8, 2011 1:00 PM
    • Unproposed as answer by Erene Ong Monday, July 11, 2011 7:00 AM
    Friday, July 8, 2011 12:59 PM
  • Hi. Having a similar issue installing sample data but when I try to run the suggested "Create-ZentityPivotCollectionFromResourceType" command in Powershell its not found see below:

    PS C:\Program Files (x86)\zentity\PowerShell scripts> create-zentityPivotCollectionFromResourceType Zentity.ScholarlyWorks Journal


    The term 'create-zentityPivotCollectionFromResourceType' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.

    At line:1 char:46

    + create-zentityPivotCollectionFromResourceType <<<<  Zentity.ScholarlyWorks Journal

        + CategoryInfo          : ObjectNotFound: (create-zentityP...romResourceType:String) [], ParentContainsErrorRecord


        + FullyQualifiedErrorId : CommandNotFoundException

    I have a number of commands loaded:















    So any help would be appreciated, happy to start a new thread if required.

    Thanks Ian

    Friday, July 8, 2011 3:34 PM
  • Hi,

    thanks for ur help. I could get the necessary commands working now.

    The problem now is that there is another error and upon looking at the logs it said

    Title: Error :: Run - Resource type does not contain any resources in the DataBase. : Zentity.ScholarlyWorks.Journal
    Parameter name: resourceTypeItems
    Message: Parameter Information
     commandName : String
     commandData : StringDictionary

    System.ArgumentNullException: Resource type does not contain any resources in the DataBase. : Zentity.ScholarlyWorks.Journal
    Parameter name: resourceTypeItems
       at Zentity.Pivot.CollectionHelper.CreateCollection()
       at Zentity.CollectionCreator.Commands.CreateCollection.Run(String commandName, StringDictionary commandData)
    Timestamp: 11/7/2011 9:12:18 AM
    Severity: Error
    App Domain: Zentity.Pivot.CollectionCreator.exe


    Monday, July 11, 2011 1:26 AM
  • I have the same problem as well now.


    Monday, July 11, 2011 11:22 AM
  • Hi Ian,

    You need to run PublishingService.ps1 script. It will load the above command.


    Monday, July 11, 2011 11:31 AM
  • Hi Kalnemi.

    Sorry, I should have been more specific. I'm getting the 2nd error that Erene is getting with the "Resource type does not contain any resources in the DataBase. : Zentity.ScholarlyWorks.Journal"

    This is when I run the "create-zentityPivotCollectionFromResourceType Zentity.ScholarlyWorks Journal".

    I managed to resolve my first issue with Powershell permissions, not now get an error when I run the command. The error is the same in the logs as Erene.

    Thanks in advance.


    Monday, July 11, 2011 12:12 PM
  • Hi Ian,

    The database does not contain resources by default. You need to use Zentity WebUI to add resource.

    • Proposed as answer by Kalnemi Monday, July 11, 2011 12:58 PM
    Monday, July 11, 2011 12:58 PM
  • Hi,

    really thanks for the help received so far. Can I have a alternative of moving on and using the president example instead and it will work? Or do i strictly have to use the Zentity WebUI? If so may i have some general directions regarding it?

    Really thanks once again for the help

    Monday, July 11, 2011 3:32 PM
  • Follow the Getting started guide page 43-47.


    Monday, July 11, 2011 3:45 PM
  • Kalnemi

    Thanks have managed to install the Presidents example.

    I not sure if I misunderstood or haven't had the time to explore the solution, but I was hoping that there was more as part of the installation. I understand that Zentity is a framework to build on, but have struggled to install some of the examples and follow the guides in places.

    I don't have deciated time on this, so probably the reason I'm missing sections and getting issues. I thought I could follow the installation guide and then the getting started and it would be okay, but seems a more more involved than expected.

    I sure I'll have some more questions later.

    Thanks Ian

    Wednesday, July 13, 2011 8:07 AM