Problems with live writer


  • I have tried to find a solution for days with no result. I have two blogs that word allright with live writer. Then I have one that I can't add. It says the server can't find and that I should check the domain. I have enabled xmlrpc so I don't know what the problem is.

    I also have another blog I'm trying to add where I get the message that it couldn't connect to the blog and there was some trouble at and then it says:

    MovedPermanently: Moved Permanently

    and that you have to correct the error.
    Saturday, May 09, 2009 3:18 PM

All replies

  • Can you get to in your web browser? It should say "XML-RPC server accepts POST requests only." if it's working properly. Can you also try the same with the xmlrpc.php on your other blog, taking special note whether it's redirecting you to a different URL?

    Wednesday, May 13, 2009 11:50 PM
  • Yes they both say "XML-RPC server accepts POST only". In fact now I can't post with any of the blogs that used to work either they also give the message "Moved Permanently"
    Thursday, May 14, 2009 8:56 AM
  • I installed live writer again and now the regular blogs work as the should. The ones without numbers in the URL.

    However the blogs that have numbers in the domain name don't work and I hoped there would be
    a solution to this. It still says it can't find the xmlrpc.php.
    Monday, May 18, 2009 10:36 AM
  • Do you have blog instaled at URL > or –> using some redirect from non-www to www variant of domain with .htaccess?

    Is this Wordpress? –> Do you have in BLOG setting (in Wordpress) set right path to files?

    Hosting of both domains is this same?
    Thursday, May 21, 2009 5:00 PM
  • Hi!

    I'm using a redirect with .htaccess from www to the non www variant of the blog in the blogs that work. The other blog that doesn't work, on another totally different account (same host) I don't use the redirect yet. I will try and see if that helps. But do you really have to redirect the blog for it to work?
    Friday, May 22, 2009 5:10 PM