locked
cannot create homeserver.com personalized account in remote web access wizard - always error with no code RRS feed

  • Question

  • hi there,

    i was so excited to get this windows home server up and running (on hyper-v) and it is great so far.

    i wanted to use the microsoft personalized domain feature which creates a personalized sub-domain for me using the homeserver.com -

    the first time i tried it i created a new name (mattlok.homeserver.com) through my windows live account, but after 10 minutes it seems to fail with an error message and to try again later without any error codes.

    then i tried it again the second and up to the tenth time accept instead of creating a new name, i chose my existing name that i first created which appeared by default the second time round and so forth.  Again it continues to fail with the same error message.

    so then i decided to create another new name with my wife's name (neschelle.homeserver.com) and again the same problem.

    so i am confused to the issue.  I live in Canada so that would be the only other thing i can think of.  But i have read from other posts from other people around the world working.

    unfortunatley none of these people are system engineers who can give me good details (such as DNS settings, or internal AD domain, etc) the most i got from the advice was to click repair.

    any help is appreciated.

    thx


    MattLok
    Monday, April 11, 2011 5:57 AM

All replies

  • btw

    all the error said "domain was not setup. wait a few minutes and run the wizard again.  an unexpected or unknown problem has occured.  please wait a few minutes and try again later.'


    MattLok
    Monday, April 11, 2011 6:00 AM
  • Not familiar with a Virtualized setup, but it should be similar to a hardware setup..  

    Have you set a static IP on your WHS server, so that it is always the same IP address inside your network?

    Have you port forwarded the correct ports on your router's port forwarding settings to your WHS?    

     

    I believe the 3 ports that you need to forward are 80, 443, and 4125, protocol is TCPIP.

     

    (I'm in Canada, and have no problem reaching my server remotely)

    Tuesday, April 12, 2011 1:35 PM
  • hey

    thanks for the suggestion.  i only have 1 subnet so all the IP are the same address inside my network,

    however i did not open port 4125, so i tried that and i even rebooted.

    but no luck still.

    now i do have a domain controller so basicly here's my ip

    whs ip: 10.0.55.35

    subnet mask: 255.255.255.0

    gateway: 10.0.55.1 (D-Link dir655 router)

    DNS: 10.0.55.10 (my primary domain controller for Active directories)

    DNS: 8.8.8.8 (google's dns server)

     

    I even tried creating a new windows live account and creating a new sub-domain, but no luck.

    i can't be the only person with this problem....


    MattLok
    Friday, April 15, 2011 6:01 AM
  • btw, i have no problems hitting my server since i am using dnsexit for my dynamic dns.

    my problem is using windows homeserver.com to register the remote web access so that i can use a proper ssl and i heard that the new whs 2011 has a builtin agent for dynamic dns.  these are the 2 key thing i am looking for.


    MattLok
    Friday, April 15, 2011 6:03 AM
  • Here are a few basic suggestions...

     

    From another PC on the same network if you open a browser and enter the url

    http://10.0.55.35 

     

    Does that bring up the windows home server webpage, if it does then at least the webpage is active, so your problem is either with port forwarding, or DNS..  If that doesn't work then the webpage isn't even active on the server.

     

    If that works the next thing to try is to check DNS... so open a Command prompt and enter 

    ping xxxxxxxx.homeserver.com

     

    If that resolves to your IP address that your ISP has assigned to you, then DNS is working correctly, if that doesn't work then the DNS entry is not getting saved on whatever DNS server you are using.

     

    You could also try a trace from the internet back to your server using:

    http://network-tools.com/

    Select Trace, and enter your server URL  xxxxxxxxxx.homeserver.com  if that doesn't work then I guess your domain name hasn't propogated to other DNS servers.

     

    I use the following DNS (OpenDNS)

    208.67.222.222
    208.67.220.220

    If all of that actually works then it would lead me to believe that the problem is with the port forwarding, or a firewall setting.

     

    Friday, April 15, 2011 1:04 PM
  • Hey thanks for the replay.

    i tried everyhitng an it doesn't work

    however what i did find out is that there is an issue using static IPs.  everyone i have read online forums and blogs have the exact same issue with the exact same router.

    how some people got around it is by enabling DHCP and having upnp on the router get picked up by the WHS 2011.

    I even hard coded the DNS from Rogers HiSpeed internet and it still did not work.  my live ID works, and i can create, it's just the DNS that does not propogate up the Microsoft DNS server.

     

    Currently i have to use DNSExit in order to point dynamic IP so i know that works with Rogers DNS.

    Actually now that i think about it.  Maybe I need to disable my DNSexit agent.

    let me try that first.


    MattLok
    Tuesday, April 19, 2011 2:07 AM
  • Hi Mattlok,

    Your domain mattlok.homeserver.com doesn't resolve on the internet, so that means that your server is not able to communicate to the DNS service to set it up and configure it, which means you need to fix your out bound internet connection. 

    Also, make sure your LiveID doesn't have any special characters in it, as mentioned in the other thread you found me on.

    http://social.microsoft.com/Forums/en-US/whssoftware/thread/67e03711-855d-4dcc-9885-be3ca368f7e4

    if you don't wish to change your password because it has special characters in it, you'll need to install the updated IDCRL:

    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=9ba199ef-3086-4f12-970d-8745be104600 

    Tuesday, April 19, 2011 2:55 AM
    Moderator
  • Hi Sean,

    Thank- you so much for your prompt reply.

    Just to confirm.

    - i do not have any special characters in my password only letters and numbers.

    as for the outbound:

    i can confirm

    - using services like DNSexit and DynDNS where sub-domain information needs to recieve IP information from my server for the DNS works no problem (mattlok.linkpc.net)

     

    how can i test communication to the homeserver.com DNS servers from my whs2011?

    also in the service.msc, what service does whs2011 use to act as the dynamic DNS agent to send back the IP information?

    also (just thought of this) does the hyper-v virtual network cause any issue?  it does have a mac address and a static ip and the DNS is pointing to my isp (rogers cable internet)

    i hope this may shed some light.

    thx

    matt


    MattLok
    Tuesday, April 19, 2011 1:30 PM
  •  This post helped a bunch, I'm one step closer to solving this issue. The IP Address provided by the ISP (AT&T U-Verse) is not the same as the IP Address of the server. So when I typed in the IP Address of the server...... I get an unsecure certifcated and asked if I want to connect anyway. I connect and my Remote Access screen comes up after logging onto the page.

     I was able to ping the URL of the server xxxxxxxxxxxx.homeserver.com and get excellent results.

     I tried to trace is using network-tools.com and it failed. (Timed Out)

     Any suggestions?

    Saturday, August 13, 2011 8:30 PM
  • djfourmoney, rather than resurrecting old threads with additional questions which are often not as relevant to the original subject as you might think, please post a new question, stating clearly the issue you're having and the steps you've already taken to attempt a resolution.
    I'm not on the WHS team, I just post a lot. :)
    Saturday, August 13, 2011 9:16 PM
    Moderator