locked
safely removing hardware lag with OneCare 2.0 RRS feed

  • General discussion

  •  

    I have noticed that after installing OneCare that there is a considerable lag when left clicking on the safe hardware removal icon in the taskbar.  Once I manually change the settings to turn off all protection from OneCare, everything works as it normally should-without any lag.  Don't know if anyone else has had this issue, and there's WAY too many threads around here to look through, so.... any ideas on a fix?  My system: Core 2 Duo 6550 @ 2.625, 2x 1gig ddr2 800 patriot mem, 2x WD HDD raid 0, 8800GS, 650i ultra mobo.  My system is not used to any lag lol, and it is kinda inconvienent to have to wait to unplug my flash drive.  Any info about this would be appreciated.  Also to note, I have the full version of OneCare-no beta.

     

    Also not trying to "bash" OneCare, but I have a desktop PC that is on my very secure home network (I restrict by MAC & IP address, which makes me feel just a bit safe Smile ).  I fail to see the need for the "Automatically suspend all Home or work locations when you are connected to any network in a public place".  My Desktop isn't going anywhere... and when I uncheck it i have to see the "action required" all the time.... Maybe something to look into for the new 2.5 beta (which I have not tried out... yet)

    Saturday, May 3, 2008 1:14 AM

All replies

  • I've never seen anyone report the issue you are reporting with a lag on safely remove devices. It seems like it may be OneCare, but it may be OneCare in concert with whatever driver is loaded for your USB controller. That's only speculation on my part. Does the lag go away if you only disable virus protection *or* the firewall, or only if you disable both?

     

    On the public/private network issue - leave that checked. As long as the network you are connected to is identified initially as Home or Work, it will never switch to protected mode for an unidentified network - you aren't connecting to an unidentified network, so that setting doesn't affect you. If you purchase a new router, you'll need to identify the network again, as that detection will kick in to advise that it needs to know if you are on a public network or private.

    -steve

     

    Saturday, May 3, 2008 2:19 AM
    Moderator
  • Thanks Steve for responding to my issue so quickly.

     

    This only appears to happen when the virus protection is on.  When I click on the remove hardware icon it takes anywhere from 2-5 seconds for the list to appear.  With the virus protection off, it pops up immediately after the icon is clicked.

     

    Could this be because OneCare is currently scanning the device?  I only have it plugged in for maybe 10 minutes max. before removing it, but then again it's only a 2 gig flash drive...  It usually takes long enough that the taskbar retracts before the menu (i normally have 4 removable items) actually displays.

     

    Also I haven't looked anywhere in the forums about the automatic tune up, but I have it scheduled to run on Sunday every 4 weeks.  I keep getting a notification to tune up every week.  Not a big issue, I have just been cancelling it every time.  In the main window for OneCare, It is telling me that the next scheduled tune up is June 1st, but today (May 4th) I got a notification that OneCare is starting a scheduled tune up.

     

    Thanks again for your quick response, it was appreciated.

     

    Aaron

     

    Sunday, May 4, 2008 9:52 PM
  • You're welcome, Aaron. I've not noticed the lag, but then I may simply think that the delay I experience is normal. ;-)

    I suspect that the scanner is interacting with the disk file system in that it needs need to scan any file on access. When it needs to see what devices are available for removal, there may be some overhead at play with the scanner. If it always takes 5 seconds to appear, I'd say that it pretty long unless you've got a big list of available devices to stop. If it is usually about 2-3 seconds, that wouldn't be too annoying to me and is probably what I usually see.

    As for the Tune-up schedule. If your last Tune-up didn't complete, it will prompt again with greater frequency. If you want to reset the Tune-up schedule, ignore the "next" date that appears and simply reconfigure the schedule options and save. Alternatively, run a tune-up manually to completion and then take note of the next time it jumps up to start running. It should wait until the next scheduled time.

    -steve

     

    Monday, May 5, 2008 5:54 PM
    Moderator