locked
Windows 7 x32 RTM can not be activate 0x800700B7 RRS feed

  • Question

  • Hello.

    We have a problem with one client. I can not say what is happens and why it lost its activation information. This is a KMS client which was couple mounts activate via KMS.

    From the last week it show that os is not genuine and let not activate.

    If I am traing to issue slmgr command, a get:

    "Windows Script Host

    On a computer running Microsoft Windows non-core edition, run slui.exe 0x2a 0x800700B7 to display error text"

    if I issue slui command, I get:

    "Windows Activation

    An eror has occurred

    Code: 0x800700B7

    Cannon create a file when that file already exist".

     

    I also collect MDA Information:

    Diagnostic Report (1.9.0027.0):
    -----------------------------------------
    Windows Validation Data-->

    Validation Code: 50
    Cached Online Validation Code: N/A, hr = 0x800700b7
    Windows Product Key: *****-*****-2VJC9-XBBR8-HVTHH
    Windows Product Key Hash: k/l/EMDQdwK9OvdCkPtHG1YdosE=
    Windows Product ID: 00392-918-5000002-85769
    Windows Product ID Type: 1
    Windows License Type: KMS Client
    Windows OS version: 6.1.7600.2.00010100.0.0.004
    ID: {24FD3243-F761-4DBF-A99A-1784DE037F01}(1)
    Is Admin: Yes
    TestCab: 0x0
    LegitcheckControl ActiveX: N/A, hr = 0x80070002
    Signed By: N/A, hr = 0x80070002
    Product Name: Windows 7 Enterprise
    Architecture: 0x00000009
    Build lab: 7600.win7_gdr.101026-1503
    TTS Error:
    Validation Diagnostic:
    Resolution Status: N/A

    Vista WgaER Data-->
    ThreatID(s): N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002

    Windows XP Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    File Exists: No
    Version: N/A, hr = 0x80070002
    WgaTray.exe Signed By: N/A, hr = 0x80070002
    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    OGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002
    OGAExec.exe Signed By: N/A, hr = 0x80070002
    OGAAddin.dll Signed By: N/A, hr = 0x80070002

    OGA Data-->
    Office Status: 109 N/A
    OGA Version: N/A, 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
    Default Browser: C:\KochSoft\Programs\Mozilla\firefox.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>{24FD3243-F761-4DBF-A99A-1784DE037F01}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7600.2.00010100.0.0.004</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-HVTHH</PKey><PID>00392-918-5000002-85769</PID><PIDType>1</PIDType><SID>S-1-5-21-1882395543-4067387563-73431576</SID><SYSTEM><Manufacturer>LENOVO</Manufacturer><Model>636937G</Model></SYSTEM><BIOS><Manufacturer>LENOVO</Manufacturer><Version>7IET37WW (1.18 )</Version><SMBIOSVersion major="2" minor="4"/><Date>20100401000000.000000+000</Date></BIOS><HWID>B8B83607018400FA</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>GMT Standard Time(GMT+00:00)</TimeZone><iJoin>1</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>LENOVO</OEMID><OEMTableID>TP-7I   </OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults> 

    Spsys.log Content: 0x80070002

    Licensing Data-->
    On a computer running Microsoft Windows non-core edition, run 'slui.exe 0x2a 0x800700B7' to display the error text.
    Error: 0x800700B7

    Windows Activation Technologies-->
    HrOffline: 0x00000000
    HrOnline: 0x00000000
    HealthStatus: 0x0000000000000000
    Event Time Stamp: 9:15:2011 12:39
    ActiveX: Registered, Version: 7.1.7600.16395
    Admin Service: Registered, Version: 7.1.7600.16395
    HealthStatus Bitmask Output:


    HWID Data-->
    HWID Hash Current: OgAAAAEABAABAAIAAAABAAAABQABAAEAJJTW2hEdSOTiFT7G9O4mJLqUXNDUFm9WiKaKCWJIQsYqhQ==

    OEM Activation 1.0 Data-->
    N/A

    OEM Activation 2.0 Data-->
    BIOS valid for OA 2.0: yes
    Windows marker version: 0x0
    OEMID and OEMTableID Consistent: yes
    BIOS Information:
      ACPI Table Name    OEMID Value    OEMTableID Value
      APIC            LENOVO        TP-7I  
      FACP            LENOVO        TP-7I  
      HPET            LENOVO        TP-7I  
      BOOT            LENOVO        TP-7I  
      MCFG            LENOVO        TP-7I  
      SSDT            LENOVO        TP-7I  
      ECDT            LENOVO        TP-7I  
      TCPA            LENOVO        TP-7I  
      SLIC            LENOVO        TP-7I  
      SSDT            LENOVO        TP-7I  
      SSDT            LENOVO        TP-7I  
      SSDT            LENOVO        TP-7I  
      SSDT            LENOVO        TP-7I  

    Would be great full for any clue.

    Wednesday, October 26, 2011 1:45 PM

Answers

  • "Kas Tigar" wrote in message news:4ebcc4c1-6368-4684-9c63-bfc10269b140...

    Hello.

    We have a problem with one client. I can not say what is happens and why it lost its activation information. This is a KMS client which was couple mounts activate via KMS.

    From the last week it show that os is not genuine and let not activate.

    If I am traing to issue slmgr command, a get:

    "Windows Script Host

    On a computer running Microsoft Windows non-core edition, run slui.exe 0x2a 0x800700B7 to display error text"

    if I issue slui command, I get:

    "Windows Activation

    An eror has occurred

    Code: 0x800700B7

    Cannon create a file when that file already exist".

     

    I also collect MDA Information:

    Diagnostic Report (1.9.0027.0):
    -----------------------------------------
    Windows Validation Data-->

    Validation Code: 50
    Cached Online Validation Code: N/A, hr = 0x800700b7
    Windows Product Key: *****-*****-2VJC9-XBBR8-HVTHH
    Windows Product Key Hash: k/l/EMDQdwK9OvdCkPtHG1YdosE=
    Windows Product ID: 00392-918-5000002-85769
    Windows Product ID Type: 1
    Windows License Type: KMS Client
    Windows OS version: 6.1.7600.2.00010100.0.0.004



    Licensing Data-->
    On a computer running Microsoft Windows non-core edition, run 'slui.exe 0x2a 0x800700B7' to display the error text.
    Error: 0x800700B7




    Would be great full for any clue.

    You would probably be better to ask for assistance in the ITPro forums – These WGA forums are designed for consumer assistance s our knowledge of KMS/MAK activation is limited.
    Having said that, it looks as if access has been denied to replace one of the files involved in the Software Protection schema/
    I would think that recreating the Licensing store may help solve the problem. Note that you may have to re-enter the KMS server IP, etc. afterwards, as well as the Key/Activation.
     
    Recreate the Licensing Store
    1) Click Start button.
    2) Type: CMD.exe into the 'Search programs and files' field
    3) Right-Click on CMD.exe and select Run as Administrator
    4) Type: net stop sppsvc (It may ask you if you are sure, select yes)
    Note: the Software Protection service may not be running, this is ok.
    5) Type: cd %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform
    6) Type: rename tokens.dat tokens.bar
    7) Type: cd %windir%\system32
    8) Type: net start sppsvc
    9) Type: slui.exe
    10) After a couple of seconds Windows Activation dialog will appear. You may be asked to re-activate and/or re-enter your product key or Activation may occur automatically.

    Reboot and Post back with a new MGADiag report
     

    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth
    • Proposed as answer by Darin Smith MS Wednesday, October 26, 2011 9:14 PM
    • Marked as answer by Kas Tigar Friday, October 28, 2011 11:38 AM
    Wednesday, October 26, 2011 6:12 PM
    Moderator
  • I have solved the problem with help of Noel's post.

    After I have tried the solution suggestion, I was still not able to activate. SPPSVC Service was running but I did not noticed last time, that token.dat file was not recreated.

    After quick analysis I have found out, that permissions for AppData folder are not the same as for NetworkService.

    I have get ownership of entire NetworkService folder, replaced permissions of all child elements with from the parent and set NetworkService as owner again.

    After that the system was immediately activated.

    The only question I still have is - why did it happened? I will spend some time with eventlog to find some clue.

    Thanks Noel again for your advice!

    • Marked as answer by Kas Tigar Friday, October 28, 2011 11:31 AM
    Friday, October 28, 2011 11:31 AM

All replies

  • "Kas Tigar" wrote in message news:4ebcc4c1-6368-4684-9c63-bfc10269b140...

    Hello.

    We have a problem with one client. I can not say what is happens and why it lost its activation information. This is a KMS client which was couple mounts activate via KMS.

    From the last week it show that os is not genuine and let not activate.

    If I am traing to issue slmgr command, a get:

    "Windows Script Host

    On a computer running Microsoft Windows non-core edition, run slui.exe 0x2a 0x800700B7 to display error text"

    if I issue slui command, I get:

    "Windows Activation

    An eror has occurred

    Code: 0x800700B7

    Cannon create a file when that file already exist".

     

    I also collect MDA Information:

    Diagnostic Report (1.9.0027.0):
    -----------------------------------------
    Windows Validation Data-->

    Validation Code: 50
    Cached Online Validation Code: N/A, hr = 0x800700b7
    Windows Product Key: *****-*****-2VJC9-XBBR8-HVTHH
    Windows Product Key Hash: k/l/EMDQdwK9OvdCkPtHG1YdosE=
    Windows Product ID: 00392-918-5000002-85769
    Windows Product ID Type: 1
    Windows License Type: KMS Client
    Windows OS version: 6.1.7600.2.00010100.0.0.004



    Licensing Data-->
    On a computer running Microsoft Windows non-core edition, run 'slui.exe 0x2a 0x800700B7' to display the error text.
    Error: 0x800700B7




    Would be great full for any clue.

    You would probably be better to ask for assistance in the ITPro forums – These WGA forums are designed for consumer assistance s our knowledge of KMS/MAK activation is limited.
    Having said that, it looks as if access has been denied to replace one of the files involved in the Software Protection schema/
    I would think that recreating the Licensing store may help solve the problem. Note that you may have to re-enter the KMS server IP, etc. afterwards, as well as the Key/Activation.
     
    Recreate the Licensing Store
    1) Click Start button.
    2) Type: CMD.exe into the 'Search programs and files' field
    3) Right-Click on CMD.exe and select Run as Administrator
    4) Type: net stop sppsvc (It may ask you if you are sure, select yes)
    Note: the Software Protection service may not be running, this is ok.
    5) Type: cd %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform
    6) Type: rename tokens.dat tokens.bar
    7) Type: cd %windir%\system32
    8) Type: net start sppsvc
    9) Type: slui.exe
    10) After a couple of seconds Windows Activation dialog will appear. You may be asked to re-activate and/or re-enter your product key or Activation may occur automatically.

    Reboot and Post back with a new MGADiag report
     

    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth
    • Proposed as answer by Darin Smith MS Wednesday, October 26, 2011 9:14 PM
    • Marked as answer by Kas Tigar Friday, October 28, 2011 11:38 AM
    Wednesday, October 26, 2011 6:12 PM
    Moderator
  • Thanks for your answer Noel, but I did find this yesterday in some other thread and did already implemented but it does not help. I have generate additional MDA file:

    Diagnostic Report (1.9.0027.0):
    -----------------------------------------
    Windows Validation Data-->

    Validation Code: 50
    Cached Online Validation Code: N/A, hr = 0x800700b7
    Windows Product Key: *****-*****-2VJC9-XBBR8-HVTHH
    Windows Product Key Hash: k/l/EMDQdwK9OvdCkPtHG1YdosE=
    Windows Product ID: 00392-918-5000002-85769
    Windows Product ID Type: 1
    Windows License Type: KMS Client
    Windows OS version: 6.1.7600.2.00010100.0.0.004
    ID: {24FD3243-F761-4DBF-A99A-1784DE037F01}(3)
    Is Admin: Yes
    TestCab: 0x0
    LegitcheckControl ActiveX: N/A, hr = 0x80070002
    Signed By: N/A, hr = 0x80070002
    Product Name: Windows 7 Enterprise
    Architecture: 0x00000009
    Build lab: 7600.win7_gdr.101026-1503
    TTS Error:
    Validation Diagnostic:
    Resolution Status: N/A

    Vista WgaER Data-->
    ThreatID(s): N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002

    Windows XP Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    File Exists: No
    Version: N/A, hr = 0x80070002
    WgaTray.exe Signed By: N/A, hr = 0x80070002
    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    OGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002
    OGAExec.exe Signed By: N/A, hr = 0x80070002
    OGAAddin.dll Signed By: N/A, hr = 0x80070002

    OGA Data-->
    Office Status: 109 N/A
    OGA Version: N/A, 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
    Default Browser: C:\KochSoft\Programs\Mozilla\firefox.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>{24FD3243-F761-4DBF-A99A-1784DE037F01}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7600.2.00010100.0.0.004</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-HVTHH</PKey><PID>00392-918-5000002-85769</PID><PIDType>1</PIDType><SID>S-1-5-21-1882395543-4067387563-73431576</SID><SYSTEM><Manufacturer>LENOVO</Manufacturer><Model>636937G</Model></SYSTEM><BIOS><Manufacturer>LENOVO</Manufacturer><Version>7IET37WW (1.18 )</Version><SMBIOSVersion major="2" minor="4"/><Date>20100401000000.000000+000</Date></BIOS><HWID>B8B83607018400FA</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>GMT Standard Time(GMT+00:00)</TimeZone><iJoin>1</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>LENOVO</OEMID><OEMTableID>TP-7I   </OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults> 

    Spsys.log Content: 0x80070002

    Licensing Data-->
    On a computer running Microsoft Windows non-core edition, run 'slui.exe 0x2a 0x800700B7' to display the error text.
    Error: 0x800700B7

    Windows Activation Technologies-->
    HrOffline: 0x00000000
    HrOnline: 0x00000000
    HealthStatus: 0x0000000000000000
    Event Time Stamp: 9:15:2011 12:39
    ActiveX: Registered, Version: 7.1.7600.16395
    Admin Service: Registered, Version: 7.1.7600.16395
    HealthStatus Bitmask Output:


    HWID Data-->
    HWID Hash Current: OgAAAAEABAABAAIAAAABAAAABQABAAEAJJTW2hEdSOTiFT7G9O4mJLqUXNDUFm9WiKaKCWJIQsYqhQ==

    OEM Activation 1.0 Data-->
    N/A

    OEM Activation 2.0 Data-->
    BIOS valid for OA 2.0: yes
    Windows marker version: 0x0
    OEMID and OEMTableID Consistent: yes
    BIOS Information:
      ACPI Table Name    OEMID Value    OEMTableID Value
      APIC            LENOVO        TP-7I  
      FACP            LENOVO        TP-7I  
      HPET            LENOVO        TP-7I  
      BOOT            LENOVO        TP-7I  
      MCFG            LENOVO        TP-7I  
      SSDT            LENOVO        TP-7I  
      ECDT            LENOVO        TP-7I  
      TCPA            LENOVO        TP-7I  
      SLIC            LENOVO        TP-7I  
      SSDT            LENOVO        TP-7I  
      SSDT            LENOVO        TP-7I  
      SSDT            LENOVO        TP-7I  
      SSDT            LENOVO        TP-7I  


    I home some one can help me.

    Thursday, October 27, 2011 6:57 AM
  • I have solved the problem with help of Noel's post.

    After I have tried the solution suggestion, I was still not able to activate. SPPSVC Service was running but I did not noticed last time, that token.dat file was not recreated.

    After quick analysis I have found out, that permissions for AppData folder are not the same as for NetworkService.

    I have get ownership of entire NetworkService folder, replaced permissions of all child elements with from the parent and set NetworkService as owner again.

    After that the system was immediately activated.

    The only question I still have is - why did it happened? I will spend some time with eventlog to find some clue.

    Thanks Noel again for your advice!

    • Marked as answer by Kas Tigar Friday, October 28, 2011 11:31 AM
    Friday, October 28, 2011 11:31 AM
  • "Kas Tigar" wrote in message news:b98c3e61-5b23-40d8-ab57-87cbfafa3300...

    I have solved the problem with help of Noel's post.

    After I have tried the solution suggestion, I was still not able to activate. SPPSVC Service was running but I did not noticed last time, that token.dat file was not recreated.

    After quick analysis I have found out, that permissions for AppData folder are not the same as for NetworkService.

    I have get ownership of entire NetworkService folder, replaced permissions of all child elements with from the parent and set NetworkService as owner again.

    After that the system was immediately activated.

    The only question I still have is - why did it happened? I will spend some time with eventlog to find some clue.

    Thanks Noel again for your advice!

     
    **many*** thanks for the feedback!
    It’s rare that anyone comes back with valuable data for future clients – and even more rare that such data is probably sufficient to create a proper fix for the problem.
     
    This post gives us (hopefully) sufficient data that we can craft something that works for future clients.
    Thanks again – and VERY good luck for the future!
     
     

    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth
    Friday, October 28, 2011 9:43 PM
    Moderator