locked
problems accessing personal domain/web site RRS feed

  • Question

  • Still in the installation/ setup phase of WHS, therefore posted here, instead of software.

    My hardware setup:

    computer 1. WHS w/PP3 ( hp pavilion pc- p6320f) connected (ethernet) to D-Link DIR 615 router which is connected (ethernet) to a2WIRE AT&T cable modem which is connected to the DSL wall socket.

    computer 2. Dell desktop running Windows 7 Ultimate wirelessly connected to the internet and not physically cabled to the home network. There are other computers in the house also connected to the internet all wirelessly.

    I set up WHS (the remote access part, including domain name, site-under the settings tab) from the WHS control panel while on the WHS machine. Also with IE8 on that machine, I went to trusted sites and added it. (https://mysite.homeserver.com... mysite not real name of course). On computer 2, went through the connect setup steps without problems. My virus software was outdated so I then installed the free MS MSE on the dell desktop without any problems, did scan, everything OK.

    Currently doing all my work from computer 2, including accessing WHS; no problems getting on the internet, etc. If I go to network and sharing center there are 2 active networks (both designated home networks), one named dlink that corresponds to the WHS network and one named 2WIRE682 2 that was the preexisting network. When I am logged on to the 2WIRE network I can log onto the website (https://mysite.homeserver.com) and can get to the WHS Server Console that way. However, when I am on the 2WIRE network (and also not logged onto WHS Server Console remotely), if I go to the Windows Start menu and try to log onto the WHS Server console, I get the message: "This computer cannot connect to your home server. Check your network connection, make sure home server is powered on";

    Vice-versa, if I am logged onto the DLink network, I can log onto the WHS server console without problems, but I can't log onto the domain. I get the "IE can't display the webpage" message. When I click the diagnose connection problem button, I am told "problems found, the remote device or resource won't accept the connection; ... mysite.homeserver.com is not set up to accept connections on port https." I have IE8 on computer 2 also set up so that that domain is a trusted site.

    I don't know if my problem has to do with the D-Link router (I just used the defaults) or the MSE virusware/firewall or something else. I turned off the firewalls and that had no impact. When I take the Dlink router out of the system, WHS access doesn't work- get error messages in the remote access section of the settings. Please advise. Thanks.

    Sunday, July 11, 2010 8:11 PM

All replies

  • I assume you have a double NAT configuration (your router having a private subnet, your DSL modem another one on the internal interfaces. Since this is not supported, you have two options:

    Change your modem to bridge mode
    or
    Create manual port forwarding for the ports 80, 443 and 4125 in bith devices (router and modem) - in the modem to the appropriate ports of the router and in the router to the ports of the WHS.

    Best greetings from Germany
    Olaf

    Sunday, July 11, 2010 9:15 PM
    Moderator
  • Olaf,

    Thanks for your reply,

    Having two networks was not by design. I would be happy to just have one. I guess, if we just focus on the Dlink network, this would be fine and just ignore the 2WIRE network. So, if I want my Dlink network to be able to connect to https://mysite.homeserver.com what do I do?

    Specifically, do I go to my router setup (accessible from the WHS machine) and change some router settings, and then go to WHS... internet options ... and change some port settings here.

    Please fill in the blanks. Thanks.

    Sunday, July 11, 2010 10:11 PM
  • Actually it seems I should be able just to modify the router from computer 2. From computer 2 (running Win7, and with the D-Link network chosen) I go to computer -> network; there it shows me DIR-615, I click on that and log on and then one of my choices is network settings. I can modify the router settings (IP address, subnet mask, and device name and there is an optional box for local domain name). Another section is for DHCP server settings ("use this section to configure the built-in DHCP Server to assign IP addresses to the computers on the network)--- I don't think this would be applicable. The next section is Add/Edit DHCP reservation. The next section is the DHCP reservation list but I don't have any choices to modify here. And the last section is for number of Dynamic DHCP clients which notes that there are 3. My choices in this section are to revoke or reserve; again, doesn't look applicable.

    In the advanced tab there is a section for port forwarding and blanks to fill in are: 1) name, 2) application name- drop down list with games, 3) ports to open- TCP, 4) schedule, 5) IP address, 6) computer name-drop down list with named computers  , 7) ports to open-UDP, 8) inbound filter.

    There are many other choices including virtual server, application rules, firewall settings, routing.

    Please advise.

    Sunday, July 11, 2010 10:43 PM
  • It must be simpler than this (that is what I am missing). Because, if while on the DLink network, I go to https://WHSIPaddress (where WHS Ip address is the actual IP address number) it takes me to my WHS web site. Granted it warns me not to go to the site because of "unable to verify certificate", and when I go there anyway, it displays on the url line a red security badge with an X in it and next to that it says certificate error.

    Of note, when I put https://mysite.homeserver.com on the url line and hit enter, at the bottom of the web browser it says connecting to site 74.166.119.242, then done and I am at the "IE can't display the webpage" page. Where did that IP address come from?

    Monday, July 12, 2010 12:48 AM
  • Ok, so I go back into the D-Link DIR-615 router software, looking for 74.166.119.242. Under device information it tells me that that number is the WAN IP address. Then I went to the WHS server console, and in the remote access section-> domain name -> details ... that is the web site IP address. 

    So, I am confused. Is it a port forwarding issue, because when I go to the port forwarding area of the routing software I put in the computer name, IP address, TCP ports 80, 443, and 2145, schedule always, inbound filter- allow all and hit save settings it seems to go through the process, but when I go back to the port forwarding rules section those settings have not persisted.

    Glub, Glub, Glub, I am drowning. Help.

    Monday, July 12, 2010 1:24 AM
  •  On 7/11/2010 8:24 PM, dlazenby wrote:

    Ok, so I go back into the D-Link DIR-615 router software, looking for 74.166.119.242. Under device information it tells me that that number is the WAN IP address. Then I went to the WHS server console, and in the remote access section->  domain name ->  details ... that is the web site IP address.

    So, I am confused. Is it a port forwarding issue, because when I go to the port forwarding area of the routing software I put in the computer name, IP address, TCP ports 80, 443, and 2145, schedule always, inbound filter- allow all and hit save settings it seems to go through the process, but when I go back to the port forwarding rules section those settings have not persisted.

    Glub, Glub, Glub, I am drowning. Help.

    On your D-Link router under your basic setup, do you have it set as PPPoE, PPPoA, Static IP, or Automatic (DHCP)?  If you've got it set up as PPPoE, then it's a port forwarding issue (or Comcast is blocking one of the ports that you need -- most likely Port 80).  The 74.x.x.x IP address is the IP address that your ISP gives your modem (or in your case, the D-Link Router, as the modem is just a tunnel).  It's how you would connect from outside (if you didn't have a domain set up).

    Going back to your original post, let me see if I understand this correctly.  You have wireless networking enabled on both the modem and the D-Link router (hence why you see both D-Link and 2-WIRE).  If you connect through the 2-WIRE wireless, you can access the server via the Remote Access (your domain.homeserver.com site name) but not through local access.  If you log into the D-Link, you can access the server via the local accesses, but not through the Remote Access (your domain.homeserver.com name).

    Some questions for you:

    1.  What is the color on your Windows Home Server Connector when you're logged into the D-Link network (or connected through an ethernet cable)?  Does it say that Port Forwarding failed or that it couldn't register your domain name?
    2.  If you go to the Library or a coffee shop, can you access your Home Server via the domain.homeserver.com name that you set up?

    Some probabilities for you.

    Assuming that your D-Link is set up as PPPoE or PPPoA (oE is better, but you're at the mercy of what your ISP will let you use), then the 2WIRE is not even an issue.  It's just a tunnel between your ISP and your router.

    If you're able to connect from a remote location to your home server, and the console isn't throwing errors about "Port Forwarding" or "Registering your site", then you're good to go.  You don't normally want to access your server from the Remote Site name if you're on the local network.

    Disable the wireless on the 2WIRE.  1) Unless you've set up a password to connect, everyone in your neighborhood is using it to get free Internet (probably not, but why give them the option).  2) It's NOT a part of your local network, so why would you want to use it when you're at home?

    Password protect the D-Link wireless network with WPA2 (or WPA-TKIP if you don't have WPA2) and make it a hard to guess passphrase.  That way everyone in your neighborhood can't potentially get into your local network and mess with your server or files (or use your connection for Free Internet).  My passphrase is "My Very Elderly Mother Just Sat Upon North Platte" to give you an idea (no, it's not that, but you get the point).  You'll have to log into the wireless with the passphrase, so tell it to remember it.

    If the D-Link is set up as Automatic DHCP, or a Static IP address from the 2WIRE modem, then you'll need to call your ISP to find out how to set it up as a PPPoE or if that's not possible, PPPoA connection.  This will require you to put your username and password in that they gave you.  It will also require you to set up DNS Servers (they will give you theirs, but you can use any DNS Servers that you want-- I use OpenDNS or Google's PublicDNS myself).

    Of the two options, PPPoE is preferred as most routers support that. If it's a PPPoA configuration, you'll need to get a gateway (which is more expensive and for the most part only available for purchase in the UK and Europe.. I've looked into it).  Most likely you'll have PPPoE as I think Qwest is about the only ISP that still uses PPPoA in the US.

    Have a great day:)
    Patrick.

    Bonus points for anyone who can tell me what my passphrase is a phonetic for... Not really, but let's see if you can figure it out.
     -- Smile... Someone out there cares deeply for you.
    Have you updated today?
    http://update.microsoft.com


    Smile.. Someone out there cares deeply for you.
    Monday, July 12, 2010 3:27 AM
  • Patrick,

    Thanks for your reply. I think the problem is the double NAT configuration. I guess I could switch the D-Link router for a switcher (I know there is a way to change the D-Link router to a switcher but it seems to complicated). Alternatively, I could replace the 2WIRE with a different dsl modem/router. I think I am going to go back to Office Max and get the D-Link Xtreme N Gigabit Router (DIR-655). It has a DSL modem port and has gotten good reviews.

    Monday, July 12, 2010 11:51 PM
  •  On 7/12/2010 6:51 PM, dlazenby wrote:

    Patrick,

    Thanks for your reply. I think the problem is the double NAT configuration. I guess I could switch the D-Link router for a switcher (I know there is a way to change the D-Link router to a switcher but it seems to complicated). Alternatively, I could replace the 2WIRE with a different dsl modem/router. I think I am going to go back to Office Max and get the D-Link Xtreme N Gigabit Router (DIR-655). It has a DSL modem port and has gotten good reviews.

    Sorry for the late reply to this.

    I would contact your ISP first, and see if you can set it up to where the modem just bridges the router to them.  Essentially, you'll set the router up as a PPPoE configuration, and have to put your username/password from the modem into the router's configuration.  It's much easier, quicker, and less expensive.

    Have a great day:)
    Patrick.


    Smile... Someone out there cares deeply for you.
    Have you updated today?
    http://update.microsoft.com


    Smile.. Someone out there cares deeply for you.
    Wednesday, July 14, 2010 5:30 PM