locked
System workflow sends email to only first user - CRM 2013 RRS feed

  • Question

  • I have a system workflow to create and send email.

    The "To" fields  is set  to owner;createdby;modifiedby.

    But the email goes to only the owner(the 1st one).

    If the sequence in "To" field is changed, then also the email goes to the first one.


    P kar



    • Edited by Kar Pallavi Tuesday, March 31, 2015 9:25 AM
    Tuesday, March 31, 2015 9:20 AM

All replies

  • Hi Pallavi,

    This may sound stupid but are you sure that recipients here in question {Owner, created by & Modified by} are not the same user. As you said that even if the sequence is changed the email is being sent to the same person and if not, are their email address same or different?


    Regards, Abhishek Bakshi If you find this post helpful then please Vote as Helpful and Mark As Answer. Check my blog on https://mydynamicscrmblog.wordpress.com/

    Tuesday, March 31, 2015 10:01 AM
  • All of them are different users with different email id's.

    Whoever  is set as the 1st one in "To" field of email receives the email.Rest two do not.

    Thanks


    P kar

    Wednesday, April 1, 2015 6:52 AM
  • Hi Pallavi,

    Well, this is something which is standard behavior of CRM hence it is sending one email rather than three. To achieve this you will have to use team-based recipients lists rather than user-based lists in your workflow. CRM currently does not support sending emails to teams but you can try "CRM Email Workflow Utilities" solution to achieve this.

    https://crmemailworkflowutilities.codeplex.com/


    Regards, Abhishek Bakshi If you find this post helpful then please Vote as Helpful and Mark As Answer. Check my blog on https://mydynamicscrmblog.wordpress.com/

    Wednesday, April 1, 2015 7:17 AM
  • Hi Abhishek,

    It is Okay to have one email.But if in "To" I am specifying 3 different fields(users), one email should go where ,

    To : USERA;USERB;USERC .............

    But it fails.The email goes only to the first user.

    Whereas if I keep multiple recipients in CC it works.

    Thanks


    P kar


    • Edited by Kar Pallavi Wednesday, April 1, 2015 9:10 AM
    Wednesday, April 1, 2015 9:09 AM
  • I understand that, I also tried replicated the same and faced the same error using a system workflow. However when I sent a normal email without using a workflow emails were sent as always. Keeping users in CC is a workaround. You can contact Microsoft for this and maybe raise a ticket.

    Regards, Abhishek Bakshi If you find this post helpful then please Vote as Helpful and Mark As Answer. Check my blog on https://mydynamicscrmblog.wordpress.com/

    Wednesday, April 1, 2015 9:27 AM