none
HPC Pack 2016 Update 2 installation error 20002, can not install server components after uninstall HPC Pack 2016

    Question

  • Hello,

    I successfully installed the HPC Pack 2016 on a windows server 2016. After uninstalling the components of the HPC Pack 2016, i got an error during the reinstallation. Uninstalling HPC components was done by Windows "Programs and Features", but propably not in the right order according to the manual. The SQL server installation is untouched. Despite the uninstallation, some "Fabric" and some "Microsoft HPC Pack Assemblies" processes are running.

    I tried to install the HPC Pack 2016, the HPC Pack 2016 Update 1 and the Update 2 Pack. I got the same error for each Pack. The installing process successfully finished the Microsoft MPI installation and the HPC client components installation, and stopped with an error during the HPC server components installation.

    The error message is: "Component Microsoft HPC Pack 2016 Server Components cannot be installed with error code 20002. Unknown error"

    Wednesday, October 10, 2018 7:08 AM

Answers

  • Looks like SQL connection issue?

    When you un-install HPC Pack 2016, could you un-install the service fabric as well? it is available in your setup folder "ServiceFabric\CleanFabric.ps1"


    Qiufang Shi

    • Marked as answer by andigx Wednesday, October 10, 2018 9:04 AM
    Wednesday, October 10, 2018 8:00 AM

All replies

  • Looks like SQL connection issue?

    When you un-install HPC Pack 2016, could you un-install the service fabric as well? it is available in your setup folder "ServiceFabric\CleanFabric.ps1"


    Qiufang Shi

    • Marked as answer by andigx Wednesday, October 10, 2018 9:04 AM
    Wednesday, October 10, 2018 8:00 AM
  • Hello,

    No, I did not uninstallation of the service fabric. How does the uninstallation of the service fabric work?


    The servicefabric folder is available in my setup folder!
    • Edited by andigx Wednesday, October 10, 2018 8:53 AM
    Wednesday, October 10, 2018 8:50 AM
  • running "CleanFabric.ps1" solved the installation problem. All "Fabric" and "HPC Assemblies" processes were stop. Thank you!
    Wednesday, October 10, 2018 9:04 AM