none
I'm trying to use asp.net but i get this: HTTP Error 403.14 - Forbidden RRS feed

  • Question

  • hi, 

    I'm still learning asp.net and when I run my site on chrome it gives me this:

    HTTP Error 403.14 - Forbidden

    The Web server is configured to not list the contents of this directory.

    <fieldset>

    Most likely causes:

    • A default document is not configured for the requested URL, and directory browsing is not enabled on the server.
    </fieldset>
    <fieldset>

    Things you can try:

    • If you do not want to enable directory browsing, ensure that a default document is configured and that the file exists.
    • Enable directory browsing.
      1. Go to the IIS Express install directory.
      2. Run appcmd set config /section:system.webServer/directoryBrowse /enabled:true to enable directory browsing at the server level.
      3. Run appcmd set config ["SITE_NAME"] /section:system.webServer/directoryBrowse /enabled:true to enable directory browsing at the site level.
    • Verify that the configuration/system.webServer/directoryBrowse@enabled <g class="gr_ gr_194 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar multiReplace" data-gr-id="194" id="194">attribute</g> is set to true in the site or application configuration file.
    </fieldset>
    <fieldset>

    Detailed Error Information:

    Module    DirectoryListingModule
    Notification    ExecuteRequestHandler
    Handler    StaticFile
    Error Code    0x00000000
    Requested URL    http://localhost:64118/
    Physical Path    C:\xampp\htdocs\77zsite
    Logon Method    Anonymous
    Logon User    Anonymous
    Request Tracing Directory    C:\Users\r2d2f\Documents\IISExpress\TraceLogFiles\77ZSITE
    </fieldset>
    <fieldset>

    More Information:

    This error occurs when a document is not specified in the URL, no default document is specified for the Web site or application, and directory listing is not enabled for the Web site or application. This setting may be disabled on purpose to secure the contents of the server.

    View more information »

    </fieldset>
    Tuesday, November 21, 2017 11:42 PM

All replies

  • I'm still learning asp.net and when I run my site on chrome it gives me this

    http://forums.asp.net/

    It's where you should post, but basically the directory on the Web server for a given Web application is not going to allow it to be listed.

    If it was the Windows O/S, you did a Dir *.* in the directory and it was set to forbid the Dir *.*,  that's kind of the essence of the forbidden on the Web server.

     https://forums.iis.net/

    You can post to the above too, because you really have IIS issues. 

      

    Wednesday, November 22, 2017 2:41 AM