locked
CRM Reporting Extensions Error - Index was outside the bounds of the array RRS feed

  • Question

  • Hi there

    I am getting an error whilst installing CRM Reporting Extensions.

    The error is in the System Checks section for Environment Checks

    "Index was outside the bounds of the array"

    Not particularly helpful that one. I have tried googling but get nothing that is obviously related. Has anybody seen this. It is currently stopping me from having a complete install.

    Many Thanks

     

    Alan

    Tuesday, February 22, 2011 11:23 PM

All replies

  • Can you please provide the relevant portion of the setup log file? By default the log file is located at %APPDATA%\Microsoft\MSCRM\Logs\BIDSExtensionsSetup.log

    Monday, February 28, 2011 7:51 PM
  • I've got the same issue, My log:

     

    ...

    11:33:17|   Info| Check PrivReportingGroupActiveDirectoryRightsValidator: Success

    11:33:17|   Info| Check CrmSqlDomainValidator: Success

    11:33:17|   Info| Check ReportServerInstanceValidator: Success

    11:33:17|   Info| Check CanPublishReportsValidator: Success

    11:33:17|   Info| Group Environment Checks

    11:33:17|   Info| Check ReportServerValidator: Success

    11:33:17|  Error| Check ReportingAccountValidator : Failure: Index was outside the bounds of the array.

     

    11:33:17|   Info| Group User Input Checks

    11:33:17|   Info| Check TargetFolderValidator: Success

    11:33:17|Verbose| Validation ran.

    11:33:17|Verbose| Validation completed.

    11:33:17|Verbose| Method exit: Microsoft.Crm.Tools.EDW.Framework.EDWTool.Run

    11:33:17|Verbose| Method exit: Microsoft.Crm.Tools.EDW.Framework.EDWTool.RunAll

    11:33:17|Verbose| Method entry: Microsoft.Crm.Tools.EDW.Framework.EDWToolCallbacks.Clear

    11:33:17|Verbose| Method exit: Microsoft.Crm.Tools.EDW.Framework.EDWToolCallbacks.Clear

     

    I've tried the tricks for fixing the issue in CRM 4.0 which were to change the Reporting services service login, i've cycled through the CRM account, the domain admin account and the local system account. the local system account squawks about using the same creds as the CRM server itself. Not sure if its a bug in CRM 2011 reporting extensions or what?

    -Mike

    Wednesday, March 2, 2011 4:43 PM
  • This looks like a bug to me.

    You have mentioned that you received this error, when Reporting Service was running as a domain admin account. Assuming that you have logs for that run of setup, can you please let me know the value of the property RSWindowsServiceAccountName? (You will find it in the log file.) 

    Since this is an error in EDW checks, you should be able to simply ignore it by creating a DWORD registry value named IgnoreChecks under HKLM\Software\Microsoft\MSCRM. and setting it to 1.

    We recommend that you do not run Reporting Service under the same account as CRM Server itself - because that would give the Reporting Service direct access to CRM databases in SQL. This opens up a possibility of malicious reports corrupting CRM data.

    Thanks,

    Arko.

    Friday, March 4, 2011 6:41 PM
  • I had the same issue

    I placed the registry key. This way I could continue with the install but that eventually failed with the following error:

     

    20:39:34|   Info| === Logging stopped: 6/13/2011  20:39:34 ===

    20:39:34|   Info| D:\Server\amd64\SrsDataConnector\SrsDataConnector.msi installed.  LocalPackage=C:\Windows\Installer\7ef57.msi

    20:39:34|   Info| CrmAction execution time; ReportingExtensionsMsiInstallAction; 00:00:01.1396484

    20:39:34|   Info| Installer Complete: SrsDataConnectorMsiInstaller

    20:39:34|   Info| Installer Start: SrsDataConnectorInstaller.Install: operation Install

    20:39:34|   Info| Executing Install action: Microsoft.Crm.Setup.SrsDataConnector.RegisterDataExtensionAction

    20:39:34|   Info| Adding extension MSCRMFETCH to RS config file c:\Program Files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services\ReportServer\RSReportServer.config

    20:39:34|   Info| Adding extension MSCRM to RS config file c:\Program Files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services\ReportServer\RSReportServer.config

    20:39:35|   Info| CrmAction execution time; RegisterDataExtensionAction; 00:00:00.0029297

    20:39:35|   Info| Executing Install action: Microsoft.Crm.Setup.SrsDataConnector.GrantAssemblyCodeGroupAccessAction

    20:39:35|   Info| Granting code group access to CRM assemblies

    20:39:35|   Info| Saving changes to RS policy file c:\Program Files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services\ReportServer\rssrvpolicy.config

    20:39:35|   Info| CrmAction execution time; GrantAssemblyCodeGroupAccessAction; 00:00:00.0029297

    20:39:35|   Info| Executing Install action: Microsoft.Crm.Setup.SrsDataConnector.RegisterServerAction

    20:39:35|   Info| Updating server WIN-8F6BKF63P03 in configuration database to have roles AppServer, AsyncService, SrsDataConnector, DiscoveryService, SqlServer, ApiServer, HelpServer, DeploymentService, SandboxServer, DeploymentManagementTools

    20:39:35|   Info| CrmAction execution time; RegisterServerAction; 00:00:00.0742187

    20:39:35|   Info| Executing Install action: Microsoft.Crm.Setup.SrsDataConnector.RestartReportingServicesAction

    20:39:37|   Info| CrmAction execution time; RestartReportingServicesAction; 00:00:02.5566406

    20:39:37|   Info| Executing Install action: Microsoft.Crm.Setup.SrsDataConnector.AddWindowsIdentityToPrivilegeGroups

    20:39:37|Verbose| Adding account sqlserver@crm2011.testlab to group LDAP://WIN-8F6BKF63P03.crm2011.testlab/<GUID=6e57b4b4-b085-4e97-9e3a-53d1b1088969> ...

    20:39:37|   Info| Account network name: sqlserver@crm2011.testlab

    20:39:37|   Info| CrmAction execution time; AddWindowsIdentityToPrivilegeGroups; 00:00:00.0478516

    20:39:37|  Error| Installer Complete: SrsDataConnectorInstaller - Error encountered

    20:39:37|  Error| Install exception.System.Exception: Action Microsoft.Crm.Setup.SrsDataConnector.AddWindowsIdentityToPrivilegeGroups failed. ---> System.Runtime.InteropServices.COMException: Name translation: Could not find the name or insufficient right to see name. (Exception from HRESULT: 0x80072116)

       at Microsoft.Crm.Tools.ActiveDsWrapper.NameTranslateClass.Set(Int32 lnSetType, String bstrADsPath)

       at Microsoft.Crm.Setup.Server.Utility.ADUtility.Rfc1779NameFromNT4Name(String nt4Name)

       at Microsoft.Crm.Setup.Server.Utility.ADUtility.AddAccountToGroup(ServiceAccount accountType, String accountName, DirectoryEntry groupEntry)

       at Microsoft.Crm.Setup.SrsDataConnector.AddAccountToGroupActionBase.AddAccountToGroup(ServiceAccount accountType, String accountName, Guid groupId)

       at Microsoft.Crm.Setup.SrsDataConnector.AddWindowsIdentityToPrivilegeGroups.Do(IDictionary parameters)

       at Microsoft.Crm.Setup.Common.CrmAction.ExecuteAction(CrmAction action, IDictionary parameters, Boolean undo)

       --- End of inner exception stack trace ---

       at Microsoft.Crm.Setup.Common.CrmAction.ExecuteAction(CrmAction action, IDictionary parameters, Boolean undo)

       at Microsoft.Crm.Setup.Common.Installer.Install(IDictionary stateSaver)

       at Microsoft.Crm.Setup.Common.ComposedInstaller.InvokeInstall(Installer installer, IDictionary stateSaver)

       at Microsoft.Crm.Setup.Common.ComposedInstaller.InternalInstall(IDictionary stateSaver)

       at Microsoft.Crm.Setup.Common.ComposedInstaller.Install(IDictionary stateSaver)

       at Microsoft.Crm.Setup.SrsDataConnector.SrsDataConnectorSetup.Install(IDictionary data)

       at Microsoft.Crm.Setup.Common.SetupBase.ExecuteOperation()

    20:39:37|Verbose| Method exit: Microsoft.Crm.Setup.SrsDataConnector.SrsDataConnectorSetup.ExecuteOperation

    20:39:37|   Info| ActivatePage(FinishPage)

     

    Guess it has something to do with the login user for one of the services. What is the correct config for this?

    Monday, June 13, 2011 7:14 PM
  • Mine did the same thing until I changed the SQL reporting service login to "domain\user" instead of "user@fullyqualifiedname" that was added automatically by the AD search function (CRM 2011 BTW)
    Wednesday, July 6, 2011 6:36 PM