locked
Iframe Report data not changing the report RRS feed

  • Question

  • Hello,

    I created a report in my Iframe using the standard Demo reports provided by microsoft. However when I add data nothing in the report will be updated.

    Also when I look at the demo VPC and look at the "At a Glance" tab on for instance the Contact entity, the report will also not be updated. I'm adding opporunities, activities, etc... and nothing in the report itself changes. I restarted the SQL Server Reporting Service but that didn't seem to do anything.

    Any idea why the new data is not caught up in the report? Or is is just a matter of waiting a while? If so, which service is determining the waiting time?
    Thursday, July 23, 2009 3:04 PM

Answers

  • There are 2 potential reasons why the report isn't showing updated data:
    1. Reporting Services is showing an earlier snapshot of the data. The rs:ClearSession=true querystring parameter should resolve this, although it is possible that the report itself has been configured to run off snapshots - use RS Report Manager to check this
    2. There may be some page caching in Internet Explorer, or possibly a proxy server if you use one. Try clearing your temporary internet files to see if that helps. You can change the caching behaviour in IIS Manager - this is done via the Http Headers tab of the virtual directory properties
    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk
    Friday, July 24, 2009 9:50 AM
    Moderator

All replies

  • How are you displaying the report ? If you're using the RS URL access you may need to add  &rs:ClearSession=true to the query string to get ReportingServices to re-execute the report - see http://blogs.msdn.com/crm/archive/2007/10/04/writing-reports-to-display-in-iframes-and-from-isv-config.aspx 
    Microsoft CRM MVP - http://mscrmuk.blogspot.com  http://www.excitation.co.uk
    Thursday, July 23, 2009 4:50 PM
    Moderator
  • Yes I added "&rs:ClearSession=true"

    But like I said the problem can't really be there because with the original demo VPC that I downloaded it also doesn't update the report if I change something... But I don't know what would cause it to update the report? Is it a certain service or something else?
    Friday, July 24, 2009 7:21 AM
  • There are 2 potential reasons why the report isn't showing updated data:
    1. Reporting Services is showing an earlier snapshot of the data. The rs:ClearSession=true querystring parameter should resolve this, although it is possible that the report itself has been configured to run off snapshots - use RS Report Manager to check this
    2. There may be some page caching in Internet Explorer, or possibly a proxy server if you use one. Try clearing your temporary internet files to see if that helps. You can change the caching behaviour in IIS Manager - this is done via the Http Headers tab of the virtual directory properties
    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk
    Friday, July 24, 2009 9:50 AM
    Moderator