locked
Problems Integrating with Outlook 2003 and Address Book RRS feed

  • Question

  • Hello All,

    I'm trying to set up a standard install of OCS 2007. I'm having some problems, mainly due to the fact i've only picked this up half way through the install.
    I've now got the address book downloading to clients (following a problem with certificates) but only some users are visible.

    Am i right in thinking this will be down to these users being the only ones with either a properly formatted phone number OR being enabled for communications server in AD? How can I solve this, as at the moment it's only showing our French users, not our UK based site, the doc seems to mention a text file to edit called "company_rules_for_normalization" or something but I can't seem to find it. (Different phone number formats +33... vs  01..)

    We also have two SIP domains set up, and this seems to be causing some problems with outlook. We have corp.internal and corp.com. Our users are familiar with corp.com and so i've set that up, but corp.internal was initially set up. Now, when attempting to use the integrated outlook features, all users are reported as 'presence unknown' and adding the user to instant messaging from within outlook results in the 'corp.internal' ID being added, which is now no longer valid. I've changed the default routing domain to .com within the OCS global properties.

    Sorry if these are very simple/newbie questions to solve, and many thanks for any help.

    Joel
    Monday, July 28, 2008 3:07 PM

Answers

  • Ok, take a look at this blog: http://blogs.pointbridge.com/Blogs/schertz_jeff/Pages/Post.aspx?_ID=17

     

    Any changes you've made within AD (like adjusting the user's SIP domain) won't appear in OCS until the next day.  The Address Book Service, which controls synching AD with OC's SQL database and then clients runs only once a day (1:30AM local time, by default).  You can manually kick off this process, the steps are in my blog above.

     

    Once you sync AD-OCS and update the address book files, then force the client to pick up a new copy of the galcontacts.db (also covered in my blog).  Your users should then appear with the new SIP names.

     

    I don't think there is any harm in leaving the .internal SIP domain, but make sure that all users are created using the .com domain for SIP names.  You can select the .com entry as the default SIP domain on the General Tab on Global Properties under the forest-level icon in the management console. 

     

    Monday, July 28, 2008 4:10 PM
    Moderator

All replies

  • Joel,

     

    I'll address each question one at a time:

     

     Joel Turner wrote:
    Am i right in thinking this will be down to these users being the only ones with either a properly formatted phone number OR being enabled for communications server in AD? How can I solve this, as at the moment it's only showing our French users, not our UK based site, the doc seems to mention a text file to edit called "company_rules_for_normalization" or something but I can't seem to find it. (Different phone number formats +33... vs  01..)

     

    You are correct in thinking that only SIP-enalbed users will appear in the OC Address Book, as that is arequirement.  Take a look at this thread for more details on the requirements and a 'work-around' if you want to include on-OCS users for dialing purposes.

     

     Joel Turner wrote:

    We also have two SIP domains set up, and this seems to be causing some problems with outlook. We have corp.internal and corp.com. Our users are familiar with corp.com and so i've set that up, but corp.internal was initially set up. Now, when attempting to use the integrated outlook features, all users are reported as 'presence unknown' and adding the user to instant messaging from within outlook results in the 'corp.internal' ID being added, which is now no longer valid. I've changed the default routing domain to .com within the OCS global properties.

     

    Does the .internal domain match your AD namespace while the .com domain matches your user's SMTP addresses?  I also don't quite follow what you mean by "adding a user to instant messaging from with outlook".  Assuming your SMTP namespace is .com then I would only deine that single SIP domain and not even use the .internal as a secondary SIP domain.

    Monday, July 28, 2008 3:35 PM
    Moderator
  • Sorry i wasn't very clear. When an email is recieved from somebody I have on my communicator contacts list they are listed as 'presence unknown'. Right clicking on the grey circle allows you to add them to your messaging contacts. This either results in a message telling me they are already added on my contact list (as i would expect) OR the old corp.internal contact being added.

    In answer to your question, the corp.internal does indeed refer to our AD, while .com refers to SMTP. Will it resolve some issues (without causing more) if i remove the corp.internal domain from the global settings?

    I'm also finding that, although we only have seven or eight users enabled for OCS and all have been converted to corp.com sip addresses, only the corp.internal addresses are appearing when looking people up through the client. This might be a time issue, as they've only been changed over earlier today.

    Thanks for the help and quick reply!

    Joel


    Monday, July 28, 2008 3:47 PM
  • Ok, take a look at this blog: http://blogs.pointbridge.com/Blogs/schertz_jeff/Pages/Post.aspx?_ID=17

     

    Any changes you've made within AD (like adjusting the user's SIP domain) won't appear in OCS until the next day.  The Address Book Service, which controls synching AD with OC's SQL database and then clients runs only once a day (1:30AM local time, by default).  You can manually kick off this process, the steps are in my blog above.

     

    Once you sync AD-OCS and update the address book files, then force the client to pick up a new copy of the galcontacts.db (also covered in my blog).  Your users should then appear with the new SIP names.

     

    I don't think there is any harm in leaving the .internal SIP domain, but make sure that all users are created using the .com domain for SIP names.  You can select the .com entry as the default SIP domain on the General Tab on Global Properties under the forest-level icon in the management console. 

     

    Monday, July 28, 2008 4:10 PM
    Moderator
  • Yes that's now doing what I thought it would. Thank you very much for your help. The integration with outlook still doesn't seem to work (users presence is not shown) but now the address list is working successfully that's a fairly minor issue.

    Thanks for the help!

    Joel
    Tuesday, July 29, 2008 8:28 AM