locked
An existing connection was forcibly closed by the remote host RRS feed

  • Question

  • i have a web app that uses the crm webservice to connect to crm -- sometimes Im getting this error on retrieve.

    What causes it and how do i catch it?

    Thursday, February 18, 2010 4:19 PM

Answers

  • If it's occasional then it could be due to socket exhaustion. See http://mscrmuk.blogspot.com/2009/11/socket-exhaustion-when-accessing-crm.html
    Microsoft CRM MVP - http://mscrmuk.blogspot.com  http://www.excitation.co.uk
    Friday, February 19, 2010 8:49 AM
    Moderator
  • Hi

    May be due to low number of ports that are available for program traffic

    try this. may help. Esure backup before try.

    1. Click Start, click Run, type regedit, and then click OK.

    2. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters

    3. Right click Parameters, point to New, click DWORD Value, and then type MaxUserPort.

    4. Right click MaxUserPort, click Modify, and then type 64000 for Value data, and set the radio button next to Decimal.
    Note: This value controls the number of dynamic ports that are available. The valid range for this value is 5,000-65,534. Specifically, this parameter controls the maximum port number that is used when a program requests any available user port from the system.

    5. Locate the following registry subkey: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters

    6. Right click Parameters, point to New, click DWORD Value, and then type TCPTimedWaitDelay.

    7. Right click TCPTimedWaitDelay, click Modify, type 30 for the Value data, and set the radio button next to Decimal.

    Note: This parameter determines the length of time that a connection stays in the TIME_WAIT state when it is closed. When a connection is in the TIME_WAIT state, the socket pair cannot be re-used. This is also known as the "2MSL" state. Typically, this value is two times the maximum segment life time on the network.

    8. Exit Registry Editor.

    9. Restart the Microsoft Dynamics CRM server.

    Regards
    Vinoth

    Friday, February 19, 2010 1:30 PM

All replies

  • If it's occasional then it could be due to socket exhaustion. See http://mscrmuk.blogspot.com/2009/11/socket-exhaustion-when-accessing-crm.html
    Microsoft CRM MVP - http://mscrmuk.blogspot.com  http://www.excitation.co.uk
    Friday, February 19, 2010 8:49 AM
    Moderator
  • Hi

    May be due to low number of ports that are available for program traffic

    try this. may help. Esure backup before try.

    1. Click Start, click Run, type regedit, and then click OK.

    2. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters

    3. Right click Parameters, point to New, click DWORD Value, and then type MaxUserPort.

    4. Right click MaxUserPort, click Modify, and then type 64000 for Value data, and set the radio button next to Decimal.
    Note: This value controls the number of dynamic ports that are available. The valid range for this value is 5,000-65,534. Specifically, this parameter controls the maximum port number that is used when a program requests any available user port from the system.

    5. Locate the following registry subkey: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters

    6. Right click Parameters, point to New, click DWORD Value, and then type TCPTimedWaitDelay.

    7. Right click TCPTimedWaitDelay, click Modify, type 30 for the Value data, and set the radio button next to Decimal.

    Note: This parameter determines the length of time that a connection stays in the TIME_WAIT state when it is closed. When a connection is in the TIME_WAIT state, the socket pair cannot be re-used. This is also known as the "2MSL" state. Typically, this value is two times the maximum segment life time on the network.

    8. Exit Registry Editor.

    9. Restart the Microsoft Dynamics CRM server.

    Regards
    Vinoth

    Friday, February 19, 2010 1:30 PM