locked
Ribbon button is not working for different users with same Security role in CRM (2011 online) RRS feed

  • Question

  • I developed one Custom ribbon button in CRM 2011.

    Once user clicked that Custom Ribbon button it will open one Custom Form.

    I'm having Two CRM users with same security role(System Admin).

    One of the user can Click that button and it opens Custom Form. But for another user its not working.

    I have added ribbon button in Customization.xml and called the form using web-resource . 

    I gave different security roles for that user. 

    Button is not Greyed out.

    Nothing happens when the user clicks that button.

    Popup blocker also turned on.

    Myself only checked for both users in IE.

    Its not working..

    I am struggling it since a Week. 

    Thanks,

    Prabaharan Kannan

    Tuesday, January 28, 2014 2:28 PM

All replies

  • Get confirmation that the issue doesn't follow the user first.  Have the user that this doesn't work for get on the working workstation and log into CRM through using the credentials of the user that is having the problem.  If the issue continues, you know it is a security role issue. 

    If it works, then the issue is with the machine.  In that case, you want to look at browser versions and patches for browser and Windows.

    Is the custom window Silverlight?  If so, then it could very well be the version of Silverlight on the workstation.


    Jason Peterson

    Tuesday, January 28, 2014 4:11 PM