locked
Windows Security Center warning conflicts with Live One Care status RRS feed

  • Question

  • I'm running One Care 2.0.2500.22 and Vista Ultimate sp1.

    One Care shows that my One Care firewall is on.

    Windows Security Center show both Windows and One Care firewalls as being OFF. This error appears in my notification tray as a red X icon, and in Windows Security Center.

    I've reinstalled One Care as instructed on this website.

    I've run OneCareFirewallRepair.exe as instructed on the website.

    How do I know if my firewall - either Windows or One Care firrewall is turned on?

    I've filed a ticket as requested on this website - with one response that didn't work, and two calls to the support line in India - no help in finding or fixing the problem. Subsequent replies to my help team suggestion email have been unanswered over the last 10 days.

    HELP!

    Thanks,
    John

    Tuesday, March 25, 2008 3:03 PM

Answers

All replies

  • Your problem is with WMI, not the firewall, it's covered in the middle post at the top of this forum:

     

    Windows Security Center WMI Fix - OneCare Green, Security Center at risk

     

    OneCareBear

    Tuesday, March 25, 2008 3:41 PM
    Moderator
  • Hi there,

    I've found a MS article on the fix
    MS link

    - but I'm missing something. it calls to run CMD at Start Search - OK, then it says to paste

    winmgmt /verifyrepository and hit enter at the prompt, but when I do I get the error message:

    'winmgmt' is not an internal or external command

    What am I missing?

    Also, I've tried:

    Method B from MVP Torgeir Bakken (more elegant)

    Open a command window (Start/Run --> cmd.exe) and run the following commands:


    net stop winmgmt
    cd /d %windir%\system32\wbem
    ren repository repository.old
         (or delete it using the command "rd /s repository" instead of the ren command)
    net start winmgmt



    Steps 1,2 & 3 went OK. The net start winmgmt didn't run from the dos prompt >, so I rebooted.


    Still no fix.


    I can live with a false/positive warning - but main main concern is: How do I know if my firewall - either Windows or One Care firewall is turned on?


    John

    Tuesday, March 25, 2008 3:57 PM
  • If OneCare is green, it is working.

    The Security Center is the broken part - the database, that is.

    You can actually turn off the Security Center monitoring of the protection.

     

    Open Windows Security Center

    Click - change the way Security Center alerts me

    Select the last option (the one it doesn't recommend.)

     

    However, the fix that you tried to run should work.

     

    The KB article notes the following:

    At the command prompt, type the following commands. Pressing ENTER after each command line:

    winmgmt /verifyrepository
    winmgmt /salvagerepository
     
    What it doesn't say is that you may need to select "Run as Administrator" from a right click on the entry for cmd.exe that appears in the Vista search results. It also doesn't say to paste the text, it says to type the text. Though, pasting should generally work. I suspect that the missing step, to run cmd.exe as administrator will solve it for you.
     
    -steve
    Wednesday, March 26, 2008 1:46 AM
    Moderator
  • Hi Steve,

    I'm curious why windows isn't seeing winmgmt and giving me the "winmgmt' is not an internal or external command" error message at the command prompt. Im running as administrator.

    It looks like the path to the winmgmt file is missing. Should I add it to my environment varaibles?

    I can turn off the security center warnings, but that never seems prudent.

    Thanks,
    John
    Wednesday, March 26, 2008 3:28 AM
  • Do you mean you are selecting "run as administrator" or that you are logged on as an administrator? If the latter, you still need to do the former. I don't know why else it isn't seeing the command as valid.

    -steve

     

    Wednesday, March 26, 2008 1:09 PM
    Moderator

  • The renaming of the Repository used to work for me but later I started getting "access denied" messages.  I am not sure why this is unless an update changed it.  I had to resort to another method:

    Click on Start>>All Programs>>Accessories
    Right click on Command Prompt and select “Run as Administrator”
    When the command window pops up you should be in your \Windows\System32 directory
    Type in the following commands:

    cd wbem
    net stop winmgmt
    rmdir /s /q repository
    net start winmgmt

    Close the command window and start Security Center.
    It will inform you that the SecCenter service is disabled so click on the button to enable it.
    After a period of time in which the Repository is rebuilt it should only report the presently installed security software.

    I have had to do a lot of this in pre-SP1 but haven't had to since installing SP1.
    Wednesday, March 26, 2008 8:16 PM
  • Thanks, Mitch.

    -steve

     

    Thursday, March 27, 2008 12:31 AM
    Moderator