locked
GalContacts.db not present RRS feed

  • Question

  • Hi

     

    I use to delete GalContacts.db on test machine to force Communicator to reload modifications (if not take sometime too long to reload it after abserver /syncnow, and unable to verify modifications).

    On one computer, when I start Communicator, the db file is not regenerated, and after a few time Communicator indicates that it is not able to retrieve contact informations.

    Is anyone know how to recreate it ?

     

    Thanks,

    Best Regards.

    Sunday, May 13, 2007 8:13 AM

Answers

  • Hi,

     

    Sorry but I didn't succeed in reproducing it again, I even retried today, with no success.

     

    Thank you for your interest.

     

    Best regards.

    Tuesday, June 26, 2007 5:36 PM

All replies

  • Doing just what you posted should recreate the file.

    Do you get any errors on the client? Can you turn on logging in the client?

    I know this sounds simple, but can you verify you are in the right profile?

    Thursday, May 24, 2007 5:45 PM
  • Can you let us know the status of your issue? If you have found a resolution, can you let us know how you resolved it? If not, please let us know.
    Wednesday, May 30, 2007 8:59 PM
  • Hi

     

    Sorry for the late reply, I was on another product lab.

    I did not solve this pb yet.

     

    Yes I was in the good profile, when I launched communicator again while the file was erased, I was watching the folder and it blinked like it was updated but still no db file. I checked file permissions, didn't find any strange configuration.

    Friday, June 1, 2007 6:59 PM
  • If the file is not being regenerated then we are most likely failing to download the file to the client.  What happens when you attempt to down the file via the browser?  If  you take a trace using netmon or ethereal you will be able to see the URL and file name.  You can also check in the directory on the server to see what the file name is to test it in a browser.

     

    Is this only happening on one client?

     

    http://fqdnofserver/abs/int/filename.dabs

     

    If you take a trace upload it and I will take a look.

     

    Louis H

    Tuesday, June 5, 2007 11:45 PM
  • Hi Louis,

     

    Thank you for your answer. Yes it happened on only one client. But I did not succeed in doing it again... I didn't know about the browser way to access it, thank you I will test.

    Tuesday, June 12, 2007 7:48 PM
  • Hi nkv,

    Can you let me know how your test went? Did this resolve the issue?

    Monday, June 25, 2007 10:03 PM
  • Hi,

     

    Sorry but I didn't succeed in reproducing it again, I even retried today, with no success.

     

    Thank you for your interest.

     

    Best regards.

    Tuesday, June 26, 2007 5:36 PM
  • So, when you say you aren't able to reproduce it again, does that mean it is working now?
    Wednesday, June 27, 2007 6:27 PM
  • Hi,

     

    We have the same problem and we have not found a solution yet.

     

    This problem is releated to one of my previous posts...

     

    http://forums.microsoft.com/Ocs2007publicbeta/ShowPost.aspx?PostID=1906747&SiteID=57

     

     

    For some users the galcontacts.db has not been created in the communicator folder in the personal profile settings on their laptops. These users are not able to make outbound calls to random phone numbers. All those users have installed Communicator with the root chain ccertificate themselves. And they have only connected with OCS via the Edge Server.

     

    GalContacts.db has been created on my laptop and I am able to make outbound calls to unregistred numbers.

     

    What is the exact url/port number/ download location for communicator to get this .db file? Can it be fetched via edge? Do we have to create some settings in ISA? How is the provisioning of the file working?

     

    I'm curious...

     

    /Thomas

     

    P.S. All these users use XP service pack 2.

     

    Friday, July 27, 2007 9:05 AM
  • We have found out that the users who can not make external phone calls (see my previous post) don't have the GalContact.db file on their PC. Communicator was not able to create the file because it cannot connect to the address book server in OCS. Normally the address book service is stored on the internal OCS machine so when connecting from Edge Server (outside) you have to take care that the address book server can be reached by applying a reverse proxy in your OCS infrasructure. The reverse proxy presenting  the address book server should be reachable from the DMZ so that external users can connect with communicator externally.

    At the moment we are implemeting the reverse proxy by following the Edge Server Deployment document from the OCS documentation. If this solution works I'll let you know.

    Regards,

    Thomas 
    Saturday, July 28, 2007 5:58 AM
  • Hi there,

     

    I am also having a problem on a laptop running OC. There were getting the message "Cannot synchronize with the corporate address book. This may be because the proxy server setting in your web browser does not allow access to the address book. If the problem persists, contact your system administrator".

     

    I renamed the galcontacts.db file and restarted OC. No addressbook was downloaded. From the laptop I could download a .dabs file and also created a test.htm file in the same folder which could be accessed.

     

    There are no permission problems and I am not sure what else to check.

     

    Does anyone have any suggestions ?

     

    Thanks

    Friday, June 27, 2008 5:01 AM
  • Which version of Windows are you using? Are you local administrator? What version of the communicator client are you using?

     

    Have you changed any default settings on the IIS web components server of the OCS frontend? Have you tried address book synchronisation by connecting to the internal OCS pool address?

    Monday, July 7, 2008 9:52 AM
  • Hi

    We are facing same issue;
    For example i have on my laptop WinXP SP2 and GalContacts is not created as such we cannot get contacts;
    on another machine hosting win2003 server R2 64 bit we can see address book and it works fine.

    Any ideas?

    Thanks
    • Proposed as answer by Jan Kroezen Thursday, August 20, 2009 1:13 PM
    Thursday, June 25, 2009 1:55 PM
  • Hi,
    We had the same problem. My colleagues en i have been puzzleling for a bit more than an day.
    The problem can be with your certificate server or certificate settings in IE.
    The communicator client usses IE settings to connegt to communications servr to create de galcontacts.db.
    Try to connect to:
    https://communicatorserver/abs/int/handler
    For example make a test.html.
    If you recieve a certificate error, than your problem might be the same as ours.
    we were missing some crl files :-) Because we didn't use an normal certificate server installation.
    IE dos not give a verry good error. But as soon as we used IE6 the erro helped us resolve the problem within 5 minutes.

    Good luck.
    Thank to
    Jeroen Geelof & Pieter de Haan.

    Op vrijdag ben ik vrij
    Thursday, August 20, 2009 1:22 PM