locked
Connector Installation Problems - Update Rollup 1 RRS feed

  • Question

  • I have a client who is using Windows Home Server 2011 with 10 clients.  We started with Vail on a couple of the none critical machines, then tried Aurora, but the staff didn't like the new logon method so when they experienced the expiry date problem we switched back to Vail.  While we were still running the Aurora beta one of the test machines stopped backing up after the December 2010 monthly Microsoft Updates, so I uninstalled the connector software, but I could never get it to re-install properly.  When we finally switched to the final product, one of the other test machines refused to connect as well.  I  always uninstalled the connector software off each machine before wiping the server to install a new release.  I had no trouble installing the connector software on the other computers.  On the two machines that it won't install on it will appear to complete and then cancel with the unexpected error message.  Prior to August 23rd, the log would show the backup client installed successfully, then it would uninstall the backup client and exit with error 1603.  I just tried it again today and now it is failing with error 1603 (unable to install update rollup 1).  I then checked all my machines and only the server has it installed (KB2554634), but none of the clients has KB2554637 installed and when I run Windows Update I get a message that there are no available updates.  According to the the article KB2554637, the only way to install this update is via Windows Update.  The two problem machines are both running Windows XP PRO SP3 with recommended updates installed.  They are also both older Dell Dimension Desktops as well.  The other computers are mostly old Dell Dimensions running Windows XP PRO SP3 and a couple of newer computers running Windows 7 Professional SP1.  When the connector fails it leaves an entry in the server and I can use remote access to access the two computers via the server.

    Any suggestions would be greatly welcome.  I've deleted everything from the task scheduler on the one machine and re-installed NET 4 manually, using Windows update and a coupe of times I've even let the connector software install it.  The result is always the same.  It appears to go to completion and then I get the unexpected error message instead of a successful install message and everything is backed out.  It always leaves an entry in the server list of computers.  Sometimes I'll remove it from the server before tring to reinstall the connector software and others times I'll just let it continue after getting the error message about the computer already exisiting on the server (all the computers have unique names).

     

    Monday, September 5, 2011 10:35 PM

All replies

  • I didn't see a response to this. I'm having exactly the same problem. Has anyone found a solution?
    Wednesday, September 28, 2011 9:39 PM
  • I have had similar problems as well, any of you MVP's has any thoughts to this and why only on WIndows XP.
    John M. Keller MCP (XP & 2003) | Security + E-Mail : itbeast@msn.com
    Thursday, September 29, 2011 12:50 AM
  • You're not supposed to use beta software in a production environment. I wonder if you've got left-overs from the beta somewhere?
    qts
    Friday, September 30, 2011 7:54 PM
  • Same exact problem here.  I am unable to install the connector software from WHS 2011 onta a Win7 64-bit Pro SP1 workstation.  Same thing, the workstation finds the server, installs software, gets to 95% done, then backs out, only giving me a vague unexpected error message and saying it erased the connector software.  As with rsifton, it leaves an entry on the Server, although the info from workstation is missing.  Ive tried just about everything I could find on the net.....unistalled .Net with special clean up tool, then reinstalled from windows setup file and also the connector software, ive started windows media receiver and scheduler services, disabled antivirus and spyware software, disabled firewall on both client and server.

     

    Interestingly, my 64-bit Win7 Home Premium HTPC installed the connector software without a hitch!  Its this a Win7 Pro issue?  Im not ready to reformat and reinstall because I honestly dont think it will help.

     

    Microsoft, please help!!!!!

     

    Fred

    Monday, October 3, 2011 8:13 PM
  • No beta Software being used, straight WHS 2011 with URP1
    John M. Keller MCP (XP & 2003) | Security + E-Mail : itbeast@msn.com
    Thursday, October 6, 2011 6:25 PM
  • Hey Fred,

    Me and another Forum Member found 3 different ways of trying to repair the connector in Window 7 when the installing the connecor fails at UWHS , give it a shot and see if it works.


    John M. Keller MCP (XP & 2003) | Security + E-Mail : itbeast@msn.com
    • Proposed as answer by ITBeast Thursday, October 6, 2011 6:32 PM
    Thursday, October 6, 2011 6:32 PM
  • I would would like to know how many have change the name of the workgroup to something other than workgroup. If I don't change the name everything works if I change the name I can no longer connect.
    Thursday, October 13, 2011 9:37 AM
  • I would would like to know how many have change the name of the workgroup to something other than workgroup. If I don't change the name everything works if I change the name I can no longer connect.

    You can't after install and there is no real reason to change it from Workgroup. Search this forum for the method to change during an installation.

    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Thursday, October 13, 2011 11:13 AM
  • I'm hitting the exact situation. The Connector software would get to about 95% complete followed by an error. The WHS 2011 definitely has KB2554634 install. I even uninstalled and reinstalled it just to make sure and it still states that it is unable to install KB2554637. I assume it is supposed to be downloaded by WHS 2011 then only computers that install the Connector software need to download it. I've wasted so much time tracking this error down. Why they didn't just allow you to install KB2554637 in case of such a failure is beyond me.

    Wednesday, December 21, 2011 12:22 AM
  • Figured I'd post back with my solution... I was having a frustrating problem with a new computer set-up with WHS2011 and all latest updates on both ends. I just couldn't get the connector to install. It would hang at about 95% indefinitely until I went to Task Manager and did an "End Task" on the installer window (since "X" was greyed out - thanks, Microsoft!), and Process Explorer indicated the hang occurring in "esSetup.exe" during the installation - Windows Installer would also log a failure in a process during installation when I killed esSetup.exe, and roll back changes (even though the connector was working perfectly while the installer hung - I could even configure and start a backup from Dashboard!). It would kill all that if the installation dies by killing esSetup.exe. Ugh...

    When I got "properties" on esSetup.exe during the hung installation, though, I found it was a component for Windows Media Center, arguably the most botched and unstable piece of crap MS ever produced. Next to Access 2010. Grand.

    My original plan was to freeze the installation after the "bin" files were written (including esSetup.exe), and overwrite esSetup.exe with a dummy/null program that just returns "success" for any parameters it's given. Before I did that, though, since I was reminded of it, I also went to "Turn Windows features on or off" and disabled Windows Media Center. Well, that required a reboot, so I did.

    When it came back, I tried the installation again. And, watching the "c:\Program Files\Windows Server\Bin" folder like a hawk (er, Falcon?), I... didn't see esSetup.exe get installed at all. Interesting.

    And, guess what? Installation finished without a hitch, no hacks needed. So, just try removing Windows Media Center. Might work!

    Monday, January 2, 2012 11:59 AM