Pin-App "ALIAS" -unpin | Some apps cannot be unpinned w/ this CMDLET RRS feed

  • Question

  • I do not know if this is by design OR a flaw in the CMDLET itself OR the CMDLET is going by a different name than what is being presented in the start menu (sometimes).

    I've attempted to run the CMDLET to show all installs apps with their GUID and App Names, but even when I go by the app name from that result...still no cigar - it's not all apps, and I can't seem to determine what differentiates an app that can be unpinned by this CMDLET vs an app that cannot be unpinned by this CMDLET.

    I've noticed that the Pin-App "ALIAS/NAME" -unpin does NOT unpin just any app, and I have yet to completely determine the rhyme or reason. I've read in other threads that the CMDLET only works for "INSTALLED" apps; I've proven this wrong as the CMDLET is unable to -unpin the Microsoft Whiteboard app which is a natively installed app of Windows 10. Maybe the app doesn't work for natively installed apps or "links".

    I tried to include a picture below for reference/example of what I'm referring to, but my account needs to be "verified".


    • Moved by Bill_Stewart Wednesday, September 4, 2019 6:07 PM This is not third party support forum
    Wednesday, February 27, 2019 4:15 PM

All replies

  • You will have to ask the author of the CmdLet.  It is not a PowerShell/Microsoft CmdLet.


    Wednesday, February 27, 2019 8:00 PM