locked
I installed Onescan and now my Network Adapters are disabled.... RRS feed

  • Question

  • Hi, I installed Onescan yesterday and at the end there was a summary of some non-original software that I allowed to be removed, thinking it was not needed or possibly an infection.  Immediately, the Onescan ended and the computer rebooted.  I had no connection to the internet at all, so I looked in Device Manager and my Realtek Audio '97 and all Network Adapters were exclamation marks.  Under Network Connections, there was nothing, no LAN.  My laptops are still connected to the linksys router that the problem computer is connected to also.  They work fine.  I went to realtek and to HP to download the original drivers for everything that said the original driver was corrupted or missing.  I did this with my laptop and copied the drivers over to the problem computer.  The audio situation went away but all the network adapters still say that the original driver was corrupted or missing even after they are updated.  This computer and all of them are running windows xp sp 2 and i tried to repair that also to no effect.  At the moment, the network adapters (12 of them) are all marked exclamation point and I can't connect to the internet at all from that computer.  I have spent most of the day looking for answers, its 3am... I hope someone can help me.
    Tuesday, June 2, 2009 10:04 AM

Answers

All replies

  • If Windows Live OneCare (I have no clue what "Onescan" is, so I assume you mean OneCare) scanned your computer and removed malware, but that removal caused further problems on your PC, please contact support:
     

    How to reach support (FAQ) - http://social.microsoft.com/Forums/en-US/onecareinstallandactivate/thread/30400b52-7f26-4ba0-bc18-17e305329d90

    If you used the free online OneCare "Safety" scanner via your web browser to scan the PC, then you should head over here:
    http://boards.live.com/safetyboards/board.aspx?BoardID=225 - since this forums is for the subscription product - http://onecare.live.com

    If you used neither of these, then I suggest contacting HP for help with restoring your PC. Alternatively, on the problem PC, remove *all* of the network adapters listed in Device Manager and reboot the PC. it should find the adapter(s) and load the drivers if they exist on the drive in the driver cache.

    -steve


    Microsoft MVP Windows Live / Windows Live OneCare & Live Mesh Forum Moderator
    Tuesday, June 2, 2009 12:53 PM
    Moderator
  • I began with the Windows Live Onecare Safety Scanner, then I downloaded the trial version of the Windows Live Onecare.  I did report it, but since it was the trial version, all that is available to me is email support and I was directed to these forums as well.

    I did remove all the network adaptors, reboot and the adapters were found but again were not functioning and showed under device manager with all exclamation points.   I followed the instructions for troubleshooting the network adapters in microsoft help but they are still not working.

    I will contact HP if I cannot get help from Microsoft with the Windows Live Onecare program.   I believe that Onescan did remove malware from my computer but after that it prompted me to delete files that I needed to connect with the internet.   From what I recall, the text was that the following files were not recognized or were not original Microsoft files and there was a prompt to delete them, so I did.  Promptly the Windows Live Onecare program ended and the computer rebooted without any access to the internet. 

    Tuesday, June 2, 2009 1:52 PM
  • You might want to give this route a shot:
     

    If you are in North America, you can call 866-727-2338 for help with virus and spyware infections. See http://www.microsoft.com/protect/support/default.mspx  for details.  For international information, see your local subsidiary Support site.

    On the other hand, you may want to just go ahead and do a repair install of Windows XP. This article provides details as well as caveats: http://www.michaelstevenstech.com/XPrepairinstall.htm

    If this is not a critical PC, then I'd put it aside until you hear back from either OneCare support of HP support via email.

    -steve


    Microsoft MVP Windows Live / Windows Live OneCare & Live Mesh Forum Moderator
    Tuesday, June 2, 2009 2:05 PM
    Moderator
  • Another thought occured to me... If you used the Safety Scanner and let it "fix" your Registry, that may be the source of your issues.

    Have tried performing a System Restore to a point before all of this began?
    The following is from the Safety Scanner Help:
     What if I accidentally remove something I need in my registry?

    Not to worry. Just like Microsoft Word, your PC has an "undo" option. In this case, it's called System Restore. Once it's finished scanning, the Windows Live OneCare safety scanner creates a System Restore point on your PC. This allows you to revert your system to its original state, before you performed the scan, in case you inadvertently remove any valid registry items.

    To access the System Restore Wizard in Windows XP:

    1. Click Start, then select All Programs.
    2. Select Accessories, then System Tools, then System Restore.
    3. In the System Restore wizard, make sure Restore my computer to an earlier time is selected, then click Next.
    4. Now you can use the calendar to select the date you performed the clean up scan and instruct your PC to revert to the way it was before you ran the scan.

    Microsoft MVP Windows Live / Windows Live OneCare & Live Mesh Forum Moderator
    Tuesday, June 2, 2009 2:08 PM
    Moderator
  • Windows System Restore had to be disabled in order to properly remove the virus.  It wasn't working anyway.  I did go back into it and re-enable it but obviously there aren't any backups available to me. 

    I had thought about the registry edit question already, but I don't know how to fix that.   The link you provided for accidentally deleting registry items takes me to the overall OneCare help site and if I type that in, nothing shows up. 

    Under Device Manager, the items that are listed are many that are not working and I was thinking one may be dependent on another to load them all, but I have no idea. 

    The disabled items under Network Adapters in Device Manager are:
    1394 Net Adapter
    Direct Parallel
    RAS Async Adapter
    Realtek RTL8139/810x Family Fast Ethernet NIC
    Realtek RTL8139/810x Family Fast Ethernet NIC - Packet Scheduler Miniport
    Realtek RTL8139/810x Family Fast Ethernet NIC - Symantec Network Security Miniport
    WAN Minport (IP)
    WAN Miniport (IP) Packet Scheduler Miniport
    WAN Miniport (IP) Symantec Network Security Miniport
    WAN Miniport (L2TP)
    WAN Miniport (PPPOE)
    WAN Miniport (PPTP)

    All of these items say "Windows cannot loadthe device driver for this hardware. The driver may be corrupted or missing. (Code 39)" 
    I have verified and updated all the drivers I could find from the HP site and Realtek.

    I tried connecting with my modem, it also doesn't work.  I am trying a windows repair right now.
    • Proposed as answer by cucupan Sunday, August 2, 2009 8:27 AM
    Wednesday, June 3, 2009 12:50 AM
  • The device list actually points to all of the components for Windows networking and your hardware. I hope that the repair install resolves it for you, but if it does not, then I still recommend that you contact HP support.
    -steve 
    Microsoft MVP Windows Live / Windows Live OneCare & Live Mesh Forum Moderator
    Wednesday, June 3, 2009 2:07 PM
    Moderator
  • Copy a clean version of ndis.sys to "C:\windows\system32\drivers" folder on your computer. Reboot.

    http://www.techsupportforum.com/microsoft-support/windows-xp-support/348804-new-network-adapters-all-drivers-corrupt-missing.html#post2185527
    • Proposed as answer by cucupan Sunday, August 2, 2009 8:28 AM
    Sunday, August 2, 2009 8:28 AM
  • Copy a clean version of ndis.sys to "C:\windows\system32\drivers" folder on your computer. Reboot.

    http://www.techsupportforum.com/microsoft-support/windows-xp-support/348804-new-network-adapters-all-drivers-corrupt-missing.html#post2185527

    I had this exact same problem, I ran the free scanner and it detected a problem with NDIS.sys. After a reboot all the network adaptors failed to start (same as items listed above).

    I've tried to replace the now missing NDIS.sys but whenever I do Windows will bue screen on boot and I have to go into safe mode, remove NDIS.sys again and then it will boot, but with the same failed networking devices.

    Any suggestions?

    I asked this question over on the forum listed in the second post (for support for the free online scanner) but I've I got there so far is abuse!

    Any help would be therefore much appreciated.
    Wednesday, November 11, 2009 6:07 PM
  • I managed to fix the blue screen problem by follwing the advice here:

    http://www.bleepingcomputer.com/forums/index.php?s=&showtopic=243839&view=findpost&p=1455904

     

    I thought I'd just post back here in case anyone else had the same issue. Basically, when the NDIS.sys file gets removed the scanner doesn;t seem to check if the original values for the NDIS driver are still in the registry (or it removes them itself, I don't know). They can be replaced bu using these vaules:

     

    -------

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NDIS]
    "DisplayName"="NDIS System Driver"
    "ErrorControl"=dword:00000001
    "Group"="NDIS Wrapper"
    "Start"=dword:00000000
    "Type"=dword:00000001

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NDIS\MediaTypes]

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NDIS\Parameters]
    "ProcessorAffinityMask"=dword:ffffffff

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NDIS\Enum]
    "0"="Root\\LEGACY_NDIS\\0000"
    "Count"=dword:00000001
    "NextInstance"=dword:00000001

    -------

     

    If you copy all between the ------- ------- bits above (including the last blank line) into Notepad and save it as something like NDISFix.reg (note it must have a .reg extension to work so make sure you don't save it as a .txt file by changing 'Save As Type' to 'All Files'). Then just double click the .reg file you've just saved and OK the message about merging into the registry, and then you should be able to put just about any version of NDIS.sys (hopefully though, not an infected version again ;-) ) back into C:\Windows\System32\Drivers\ and reboot without a blue screen and with working Network Adaptors one again!

     

    Smile

    Thursday, November 12, 2009 12:06 PM