locked
Network errors and poor throughput accessing my new NAS RRS feed

  • Question

  • The NAS stores my video library. I have a HP DV6 Laptop with 4 GB of RAM. It's running Windows 7 64 bit. Ethernet attached to my home network via a Realtec gigabit NIC.

    My old NAS was a Western Digital World Book 1TB which was 100Mb ethernet attached. It actually performed adequately but I ran out of space. I replaced it with a 4TB Thecus N2310 which is Gigabit attached.

    I use Wireshark to sniff the network and capture the errors and Intel NAS Performance Toolkit to measure the throughput of my NAS devices

    I also have a Gateway Desktop and an Asus netbook both running Win 7 that perform perfectly against the Thecus.

    I access the Thecus via Samba as a mounted drive on my Laptop. When streaming video or running NAS-PT I receive below errors and a significant loss of throughput. I should be getting about 50MB/s but due to these errors I am only getting 3-6MB/s and am unable to stream videos.

    TCP-Dup Ack, TCP Out-of-order, TCP Fast retransmission, TCP Previous segment not captured

    These errors are in order of predominance. The interesting part is if I boot in Safe Mode w/networking or if I boot Ubuntu I get excellent performance.

    I have tried running an ethernet cable directly between the Thecus and the DV6. I still received the same Network errors but my throughput did increase from 3-6MB/s to 10MB/s (insignificant). So, it's not the ethernet cable and not switches and not network congestion causing this problem.

    I've researched the heck out of this. I've modified about every advanced network setting I could find to no avail. Totally stuck.

    I welcome all questions and comments.

    Thanks, Chris

    Thursday, August 14, 2014 11:20 PM