locked
Unable to retrieve security descriptor for this frame while registering Custom Workflow Activity Assembly RRS feed

  • Question

  • Hi all,

    We have a deployment failing. in our solution we have a custom workflow activity DLL. But we're getting this error on the registration of the DLL during the import:

    Unable to retrieve security descriptor for this frame.

    <Row ss:AutoFitHeight="0" type="Plugin Assembly">
     <Cell ss:StyleID="s137" name="Time">
      <Data ss:Type="String">12:58:21.44</Data>
     </Cell>
     <Cell ss:StyleID="s137" name="ItemType">
      <Data ss:Type="String">Plugin Assembly</Data>
     </Cell>
     <Cell ss:StyleID="s137" name="Id">
      <Data ss:Type="String">ABCD.CRM.Workflows, Version=1.0.0.0, Culture=neutral, PublicKeyToken=f6dfb145835c7d06</Data>
     </Cell>
     <Cell ss:StyleID="s137" name="Name">
      <Data ss:Type="String">ABCD.CRM.Workflows</Data>
     </Cell>
     <Cell ss:StyleID="s137" name="LocalizedName">
      <Data ss:Type="String">ABCD.CRM.Workflows</Data>
     </Cell>
     <Cell ss:StyleID="s137" name="OriginalName">
      <Data ss:Type="String"/>
     </Cell>
     <Cell ss:StyleID="s137" name="Description">
      <Data ss:Type="String"/>
     </Cell>
     <Cell ss:StyleID="s137" name="Status">
      <Data ss:Type="String">Failure</Data>
     </Cell>
     <Cell ss:StyleID="s137" name="ErrorCode">
      <Data ss:Type="String">0x80048033</Data>
     </Cell>
     <Cell ss:StyleID="s137" name="ErrorText">
      <Data ss:Type="String">Unable to retrieve security descriptor for this frame.</Data>
     </Cell>
    </Row>

    This same solution uploaded on multiple other servers but is failing on just 1 of our environments.

    .Net 4.5.2 is installed on the target server.

    I could manually register the DLL using the PI registration tool and manually create workflows that use the WF activities but its not recognised when I import the dependent workflows from other environments.

    Any ideas?


    • Edited by SiN_1 Thursday, November 24, 2016 1:13 AM
    Wednesday, November 23, 2016 10:31 PM

All replies

  • My guess is that the 'Unable to retrieve security descriptor for this frame' error is from some mismatch in assembly versions (maybe .Net framework ones). If you enable tracing, the stack trace may give you a better idea of which namespace the error originates from.

    The issue with registering via the registration tool, then recreating the workflows is that they will get different primary keys, hence they don't match the imported versions. Theoretically it should be possible to hack these, but it's not simple. Or, you could make the problematic environment the master, so you create everything there, and export from there


    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Thursday, November 24, 2016 9:49 AM
    Moderator
  • We had the same error message while importing a solution containing a custom workflow activity. Similarly, the import worked fine in every environment but our production environment. It appears the issue is something with our production instance of the Sandbox service. In the solution, the custom workflow activity was registered in Sandbox isolation mode. I switched the isolation mode to None in a development environment, re-exported the solution, and it imported to production without error. We had a similar problem with a third party solution and the vendor helped point me toward this resolution.

    I haven't attempted to switch the isolation mode to Sandbox in the Plugin Registration tool now that the custom workflow activity exists in production. I also haven't been able to determine what the issue is with the Sandbox service. It seems to be functioning fine other than this.

    Thursday, January 12, 2017 7:37 PM
  • Were you able to get past this problem? We are having the exact same issue with a vendor plugin.
    Tuesday, April 25, 2017 1:55 PM
  • For the third party solution that we were unable to import, I adjusted the isolation mode within the solution file and reimported. The risk is that the adjusted plugins or custom workflow activity assemblies will not be running within the sandbox will have increased access to your system. For information about isolation mode and the sandbox do an internet search for "Plug-in isolation, trusts, and statistics" and look for an MSDN article. Sorry, I'd post the link but I'm waiting to get my account verified to allow me to do so.

    To adjust the solution file you will need to:
     - Unzip/extract the solution file
     - Open the extracted solution's folder and then open the customizations.xml file in a text editor (notepad, etc.)
     - Search for IsolationMode
     - Switch the IsolationMode value from 2 to 1
     - Repeat the last two steps (search and switch) if there are multiple assemblies in the customization file
     - Rezip/compress everything within the folder containing customizations.xml into a .zip file.

    Wednesday, April 26, 2017 2:21 PM